Opened 6 months ago

Closed 5 months ago

#2329 closed defect (fixed)

Latest MapServer patch breaks GeoMoose

Reported by: kalxas Owned by: osgeolive@…
Priority: blocker Milestone: OSGeoLive14.0
Component: OSGeoLive Keywords: mapserver, geomoose
Cc: osgeolive@…

Description

For rc3 a mapserver patch was introduced:

https://github.com/OSGeo/OSGeoLive/commit/5ddf0302b29a4868d7352cfed114ad46e84ea4b1

This patch is breaking GeoMoose? (see attachment)

Attachments (3)

Screenshot_20210430_134741.png (137.8 KB) - added by kalxas 6 months ago.
Screenshot_20210504_173138.png (72.0 KB) - added by kalxas 5 months ago.
Screenshot_20210504_173154.png (63.0 KB) - added by kalxas 5 months ago.

Download all attachments as: .zip

Change history (22)

Changed 6 months ago by kalxas

comment:1 Changed 6 months ago by sdlime

Need to generalize the value for MS_MAP_PATTERN in Apache. What's the path to all the GeoMoose? mapfiles?

comment:2 Changed 6 months ago by kalxas

Files are available in various sub-folders of /usr/local/geomoose/gm3-demo-data/

comment:3 Changed 6 months ago by jimk

/usr/local/geomoose/gm3-demo-data/

And actually, I think the only mapfiles called directly are in

/usr/local/geomoose/gm3-demo-data/*/*.map

The top level ones are only referenced by INCLUDE statements.

comment:4 Changed 6 months ago by sdlime

I'll supply a patch to the MapServer? install script ASAP.

Changed 5 months ago by kalxas

Changed 5 months ago by kalxas

comment:5 Changed 5 months ago by kalxas

Pull request merged:

https://github.com/OSGeo/OSGeoLive/pull/313

but problem persists

comment:6 Changed 5 months ago by sdlime

Ugh... Looking at the screenshots the problem is the /./ in the mapfile path. The value for MS_MAP_PATTERN is explicitly blocking that (and so will subsequent versions of MapServer? by default).

  • /usr/local/geomoose/gm3-demo-data/demo/./parcels/parcels.map - FAILS
  • /usr/local/geomoose/gm3-demo-data/demo/parcels/parcels.map - WORKS

I don't know how those paths are built within GeoMoose?.

kalxas, what's the easiest way for me to fire up a local version of OSGeoLive with this issue?

--Steve

comment:7 Changed 5 months ago by jimk

This is coming from the GeoMoose? Mapbooks:

/usr/local/geomoose/gm3-examples/htdocs/desktop/mapbook.xml
/usr/local/geomoose/gm3-examples/htdocs/mobile/mapbook.xml

Lines like:

<file>./demo/scalebars/scalebar_miles.map</file>

comment:8 Changed 5 months ago by sdlime

Is it reasonable to remove the ./ or do I need to figure out a different expression that allows /./ in the path?

comment:9 Changed 5 months ago by jimk

With this change in MapServer?, I really want to move the GeoMoose? to the /datasets/scalebar_miles.map?... style URLs (which can protect files and set the environment variables properly for each file using Apache directives) instead of /cgi-bin/mapserv?map=..., but I don't have time to do that before the OL14 release.

comment:10 Changed 5 months ago by jimk

I think the ./ can be removed from the mapbooks (sed???).

comment:11 Changed 5 months ago by jimk

I'm not sure if this misses something, but this is what I used on demo.geomoose.org.

SetEnv MS_MAP_PATTERN "^\/srv\/demo\/src\/3\.0\/gm3-demo-data\/(\./){0,1}([^\.][_A-Za-z0-9\-\.]+\/{1})*([_A-Za-z0-9\-\.]+\.(map))$"

comment:12 Changed 5 months ago by sdlime

Reasonable hint. I think I can just do something like:

"/usr/local/(mapserver specific path)|(geomoose specific path)/([\.][_A-Za-z0-9\-\.]+\/{1})*([_A-Za-z0-9\-\.]+\.(map))$"

So much easier in recently released version(s). More soon...

--Steve

Version 0, edited 5 months ago by sdlime (next)

comment:13 Changed 5 months ago by sdlime

Just submitted another pull request that should allow /./ in paths. --Steve

https://github.com/OSGeo/OSGeoLive/pull/314

comment:14 Changed 5 months ago by kalxas

Thanks, building a new iso to test and will provide feedback.

comment:16 Changed 5 months ago by sdlime

Have latest ISO running locally as a VM. Will give it another shot...

comment:17 Changed 5 months ago by sdlime

Ok, one more try. See https://github.com/OSGeo/OSGeoLive/pull/315. Tested against the nightly ISO... --Steve

comment:18 Changed 5 months ago by kalxas

Confirmed fixed in build 287

Thanks all!

comment:19 Changed 5 months ago by kalxas

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.