Opened 12 months ago

Closed 3 days ago

#681 closed defect (fixed)

no-shortcuts options not working

Reported by: rhaubourg Owned by: osgeo4w-dev@…
Priority: minor Component: Package
Version: Keywords:
Cc:

Description (last modified by jef)

Hi there,

running

.\osgeo4w-setup.exe --quiet-mode --root "X:\OSGEO4W_DEPLOY_TEST\INSTALL"  --local-install --local-package-dir "X:\OSGEO4W_DEPLOY_LOCAL\PAQUETS\http%3a%2f%2fwww.norbit.de%2fosgeo4w%2f" --autoaccept  --no-shortcuts --delete-orphans --upgrade-also  -C Libs -C Commandline_Utilities -C Desktop                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      

still creates a menu with the directory name "OSGEO4W_DEPLOY_LOCAL"

I also tested with --no-startmenu and --no-desktop, but the shortcut entries are still created

Change History (4)

comment:1 by jef, 12 months ago

Description: modified (diff)
Priority: majorminor

The shortcuts are created by the packages - each package has to respect the setting of OSGEO4W_DESKTOP_LINKS / OSGEO4W_MENU_LINKS and place the shortcut into and OSGEO4W_DESKTOP / OSGEO4W_STARTMENU. Which don't? I suppose GRASS or very old ones. In testing that cruft is probably gone.

Version 0, edited 12 months ago by jef (next)

comment:2 by rhaubourg, 12 months ago

Thanks for your light, I'll give a try with testing

comment:3 by thosch, 6 weeks ago

Hi,

I can confirm, that running OSGeo4W installer version 2.579 for a local install of only -P qgis-ltr-full with --no-shortcuts or/and --no-startmenu nevertheless creates shortcuts in the default start menu folder OSGeo4W (or --menu-name, if given).

--no-desktop on the other hand indeed disables the creation of desktop shortcuts.

The start menu shortcuts I get are:

C:\geoservice\OSGeo4W\bin\grass78.bat --gui  GRASS GIS 7.8.7
C:\geoservice\OSGeo4W\OSGeo4W.bat  OSGeo4W Shell
C:\geoservice\OSGeo4W\bin\qgis-ltr-bin.exe  QGIS Desktop 3.22.5
C:\geoservice\OSGeo4W\bin\bgspawn.exe "C:\GEOSER~1\OSGeo4W\bin\qgis-ltr-designer.bat"  Qt Designer with QGIS 3.22.5 custom widgets
C:\geoservice\OSGeo4W\bin\bgspawn.exe "C:\geoservice\OSGeo4W\bin\saga_gui.bat"  SAGA GIS 7.8.2
C:\geoservice\OSGeo4W\bin\bgspawn.exe "C:\geoservice\OSGeo4W\bin\setup.bat"  Setup

N.B. Disableing the (QGIS) shortcut is wanted, because I need to start QGIS using qgis-ltr.bat, which I edited to adapt to our company SDI environment.

comment:4 by jef, 3 days ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.