Opened 9 years ago

Closed 9 years ago

#371 closed defect (fixed)

Running setup.exe from osgeo4w 64-bit terminal tries to install 32-bit apps

Reported by: saultdon Owned by: osgeo4w-dev@…
Priority: blocker Component: Installer
Version: Keywords:
Cc:

Description

I installed the 64-bit apps I wanted from the 64bit installer, then to test updating, I launched setup from the osgeo terminal selecting Advanced Install.

Clicking Next till it starts downloading packages should grab updated 64 bit packages, but it instead downloads 32bit programs instead.

I don't have 32-bit osgeo4w installed and my Local Package Directory is a new folder that contains only the osgeo4w 64bit files.

I see it created an osgeo4w to store the 32bit programs instead of updating the currently installed 64bit ones.

 Volume in drive W is Data
 Volume Serial Number is 085F-DC09

 Directory of W:\GIS\Programs\osgeo4w-x64

08/27/2013  04:16 PM    <DIR>          .
08/27/2013  04:16 PM    <DIR>          ..
08/27/2013  04:16 PM                 0 dirlist.txt
08/27/2013  04:11 PM    <DIR>          http%3a%2f%2fdownload.osgeo.org%2fosgeo4w
08/26/2013  03:22 PM    <DIR>          http%3a%2f%2fdownload.osgeo.org%2fosgeo4w%2ftesting64
               1 File(s)              0 bytes
               4 Dir(s)  79,637,319,680 bytes free

Attachments (2)

osgeo4w-mirrors-error-trying2update.png (11.7 KB ) - added by saultdon 9 years ago.
error while trying to launch the osgeo4w.exe setup file to update installed 64bit GIS programs
setup.ini_from32bit_site.png (9.9 KB ) - added by saultdon 9 years ago.
OSGeo4W 64bit Installer downloads the 32bit setup.ini file

Download all attachments as: .zip

Change History (7)

by saultdon, 9 years ago

error while trying to launch the osgeo4w.exe setup file to update installed 64bit GIS programs

comment:1 by saultdon, 9 years ago

I attached an image to show the error (which is different) when trying to launch the downloaded osgeo4w installer for 64 bit apps instead of launching setup from the terminal.

I thought I could update existing apps using the installer I downloaded the other day, but it gives this error in the image: "OSGeo4W Setup - Use dropped mirrors?"

comment:2 by saultdon, 9 years ago

Summary: Running setup.exe from osgeo4w terminal kicks back to 32-bit appsRunning setup.exe from osgeo4w 64-bit terminal tries to install 32-bit apps

comment:3 by saultdon, 9 years ago

Tried deleting the setup.ini file in the packages folder, but that doesn't help either running setup from the terminal or the original 64bit installer.

comment:4 by saultdon, 9 years ago

The setup.ini is not being retrieved from the osgeo4w testing/64bit website but the old 32-bit one as seen in another attached image.

by saultdon, 9 years ago

OSGeo4W 64bit Installer downloads the 32bit setup.ini file

comment:5 by saultdon, 9 years ago

Resolution: fixed
Status: newclosed

Installer has been fixed and updates only 64 bit packages =)

Note: See TracTickets for help on using tickets.