Opened 14 years ago

Closed 8 years ago

#202 closed defect (fixed)

i18n problems with news and community spot lights

Reported by: arnulf Owned by: arnulf
Priority: blocker Milestone:
Component: WebSite Keywords:
Cc: arnulf, ticheler, neteler, webcom@…

Description

Community spotlights and news react unexpected when switching locales. I am only guessing but this might be due to having used different i18n modules in the lifetime of the web site plus one upgrade to a newer version. I have no solution.

Community spotlights and news appear differently depending on whether I am logged in (with editor role) or logged out.

We have to keep in mind that translation is being done by a growing bunch of people who have little or no technical background. We need this to be bullet proof and we need well defined processes on how to create translations and whether or how to translate news / community spotlights, etc.

Do we expect different News on the German language pages than on the English one? Translate all or show all in their original language regardless of locale?

Change History (10)

comment:1 Changed 10 years ago by ticheler

Cc: ticheler added
Priority: normalmajor

Hi, I've also noticed this in the past but never looked into it. It appears that news items and events will only appear on the translated OSGeo website when they have been translated (or at least have been copied to the other language). This causes e.g. Dutch readers to see news dating back to 2008 to appear on the Dutch version of the OSGeo website and see no Events appearing whatsoever.

Is there a way to configure the News and Event Views of the Drupal websites to by default show all News and Event items, irrespective of their translation status? That would make these items appear for all users using a translated GUI of the OSGeo website :-)

I looked but couldn't find it. Maybe the only option is to do something with a cloned View or so, not sure. I tried to also translate the Title and top text for these items, but that was not available by default either. (I noticed there is no other language yet that tried to translate these things)

Thanks for any feedback, cheers,

Jeroen

comment:2 Changed 10 years ago by ticheler

Issues #109 and #213 relate to this also.

comment:3 Changed 8 years ago by arnulf

Priority: majorblocker

This has to be fixed. Now. Who is going to do this?

comment:4 Changed 8 years ago by arnulf

Proposal to default that all News and Events are always displayed on every page regardless of language.

comment:5 Changed 8 years ago by ian

Owner: changed from webcom@… to ian
Status: newassigned

The Drupal view is working as intended - There's no obvious way to make it also see nodes that are in different locales (otherwise it would show multiple translations where content has been translated).

I'll dig around and see if I can find a workable solution.

As a temporary workaround, we could replace the link to "News"

http://www.osgeo.org/news

With a link to the English version of the "News (English)"...

http://www.osgeo.org/switchuilocale/en?destination=news

Users would then see all the recent news, but this would have the undesired effect of changing their language.

Alternatively we could add a bold link at the top of the news view: "For more news, see the English version of this page" (but... this link would also appear on the English page, unless we can detect the current locale using javascript)

comment:6 Changed 8 years ago by ian

The content of the view is generated BEFORE both the header and footer elements are evaluated. Therefore unfortunately the following does not work:

// VIEW HEADER
<?php
  $old_locale = localizer_get_uilocale();
  global $locale;
  $locale='en';
  $_SESSION['current_locale']='en';
?>
// VIEW FOOTER
<?php
  $locale=$old_locale;
  $_SESSION['current_locale']=$old_locale;
?>

comment:7 Changed 8 years ago by ian

Duplicate #109 closed.

http://www.osgeo.org/  <- ok
http://www.osgeo.org/startseite  <- broken Newsbox
http://www.osgeo.org/node/224 <- broken Newsbox

comment:8 Changed 8 years ago by ian

Cc: neteler webcom@… added
Owner: changed from ian to arnulf
Status: assignednew

Workaround for #202 (& #109)

If locale is not english then a bold message now appears at the top of the view: "For more news see the English version of this page" (with link to the relevant page).

@arnulf - please check that this is sufficient and close ticket.

<?php
  if (localizer_get_uilocale() != 'en'){
    print('<p style="text-align:center; font-weight:bold;">For more news see the <a href="/switchuilocale/en?destination=news">English version</a> of this page</p>');
  }
?>

comment:9 Changed 8 years ago by arnulf

As per mail: The text appears all right on the new link itself but not on the web site's main page. For some lanuagages this means that we only see "news" from 2007 which gives an impression that OSGeo is not maintained.

So we do need another solution. I am open for ideas.

One suggestion is to only include one block for news without i18n and allow people to post in their respective languages. It's not that we are suffocating in news items anyway and the odd item in Greek, German or Lithuanian language will just show that we are a truly global org.

comment:10 Changed 8 years ago by arnulf

Resolution: fixed
Status: newclosed

All news concerning global coverage should be published with language "Any" selected.

Localized news and events can be set to a specific language.

Note: See TracTickets for help on using tickets.