Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#643 closed defect (fixed)

[WMS] map= missing in onlineresource

Reported by: dmorissette Owned by: mapserverbugs
Priority: high Milestone: 4.2 release
Component: WMS Server Version: 4.2
Severity: normal Keywords:


When we do a WMS GetCapabilities and the wms_onlineresource is not set,
MapServer tries to build a default onlineresource value based on the CGI's env vars.

The problem is that this assumes that a wrapper script is used for the WMS to
set the MS_MAPFILE variable, and if the map= parameter was included in the
GetCapabilities URL, then it is not included in the default onlineresource.

Change History (5)

comment:1 Changed 12 years ago by dmorissette

  • Milestone set to 4.2 release
  • Version changed from 4.1 to 4.2

comment:2 Changed 12 years ago by dmorissette

  • Status changed from new to assigned
Looking into this now.

comment:3 Changed 12 years ago by dmorissette

  • Resolution set to fixed
  • Status changed from assigned to closed
Fixed in 4.2 branch and 4.3.  

The map= parameter is now included in the default onlineresource if it was
explicitly set in the QUERY_STRING. This was done in msOWSGetOnlineResource() so
the fix applies to WMS, WCS and WFS.

comment:4 Changed 11 years ago by dmorissette

  • Cc pramsey@… added

comment:5 Changed 11 years ago by dmorissette

*** Bug 631 has been marked as a duplicate of this bug. ***
Note: See TracTickets for help on using tickets.