wiki:MapGuideRfc19

Version 5 (modified by brucedechant, 15 years ago) ( diff )

--

MapGuide RFC 19 - Client/Web/Server Compatibility

This page contains a change request (RFC) for the MapGuide Open Source project. More MapGuide RFCs can be found on the RFCs page.

Status

RFC Template Version(1.0)
Submission DateMarch 7, 2007
Last ModifiedBruce Dechant Timestamp
AuthorBruce Dechant
RFC Statusdraft
Implementation Statuspending
Proposed Milestone1.2
Assigned PSC guide(s)(when determined)
Voting HistoryMarch 7, 2007
+1
+0
-0
-1

Overview

There is currently no mechanism in place to allow older clients to communicate with a newer MapGuide web tier or server and vice versa. This needs to be addressed in order to allow easier upgrade paths for end-users.

Motivation

There needs to be a way for a client to be able to identify the version it is so that the web tier and server can properly communicate with it. By knowing the client version the web tier and server will be able to process the appropriate operation version and use the appropriate schema version. This will allow the web tier and server to server both old and new clients and for new clients to connect to an older web tier and server. This proposal hopes to add some form of forwards/backwards compatibility to MapGuide in order to solve this.

Proposed Solution

A new HTTP parameter "CVER" needs to be added to all HTTP requests. This new parameter will be used to identify the client version. The new HTTP parameter has the following format:

MajorVersion.MinorVersion

Example:

CVER=1.2

The web tier and server will be able to use this information in order to do the operation that supports the specified client version. This will allow schema changes to take place and for multiple versions of the schema to be supported because the client tells us what version it is and therefore what schema version it supports.

This solution only helps with newer releases of MapGuide as existing releases will not contain this forwards/backwards compatibility logic. However, the web tier/server will assume that if the HTTP parameter "CVER" is not included in the HTTP request that it is an older client and to use the oldest supported version of the operation and appropriate schema version.

Currently, the web tier and server must always be the same version because there have been changes to the TCP/IP protocol between them that if different versions are used will cause them to no longer communicate with each other. There is already logic in place to identify this if mismatched web tier and server versions are used.

Implications

The web tier and server will now be able to recognize different client versions and will be able to give the proper response, as long as, they support the version of the client.

Test Plan

Simulate old client and new client operations to the web tier/server.

Funding/Resources

Autodesk to provide resources / funding.

Note: See TracWiki for help on using the wiki.