Opened 13 years ago

Closed 13 years ago

#880 closed defect (fixed)

Grass 6.5 wxpython location wizard: UTM zone selector widget is frozen

Reported by: epatton Owned by: grass-dev@…
Priority: normal Milestone: 6.5.0
Component: wxGUI Version: svn-develbranch6
Keywords: location wizard, wxpython, gui Cc:
CPU: x86-64 Platform: Linux

Description

Using 6.5 svn compiled from Jan.17th source, Ubuntu Linux 9.10.

The UTM zone selection widget is frozen in the wxpython location selection wizard.

Steps to reproduce:

  1. grass -gui
  2. Define new location with Location wizard
  3. 'Select coordinate system parameters from list'
  4. In search box, choose projection code "UTM".
  5. Choose radio button 'Datum with associated ellipsoid'.
  6. The default projection zone is 30, but if you click in the box to enter a new projection zone, the value changes to '1' and cannot be either deleted with backspace, or incremented with the up/down arrow widget to the right of the dialog box.

~ Eric

Change History (3)

comment:1 by hamish, 13 years ago

IIUC Martin has ported Michael's fix for this from 6.4 to 6.5 and trunk in the last 24 hours. Try, try again?

comment:2 by cmbarton, 13 years ago

If this hasn't been ported yet, I can do it in a couple of days. The semester is just starting here and I'm tied up getting my classes launched. But I'll have some spare moments later in the week (I hope).

Michael

comment:3 by epatton, 13 years ago

Resolution: fixed
Status: newclosed

It's looks like the change was ported to 6.5; I svn up'ed and all is well!

The location selection wizard is looking really nice guys, good job! This was my first time actually using it (I use text interface mostly).

Closing bug,

~ Eric.

Note: See TracTickets for help on using tickets.