Opened 10 years ago

Closed 10 years ago

#877 closed defect (fixed)

wxGUI: Location wizard bug when creating LatLong location

Reported by: neteler Owned by: martinl
Priority: blocker Milestone: 6.4.0
Component: wxGUI Version: svn-releasebranch64
Keywords: location wizard, wingrass Cc: grass-dev@…
CPU: Unspecified Platform: MSWindows Vista

Description

  • Launch winGRASS
  • On the right-hand side select Location Wizard under Define new location
  • Leave the GIS Data Directory field as is but choose a descriptive name for the Project Location
  • Continue to the next page
  • Choose Select Coordinate System parameters from a list and continue
  • Type in ll for the Projection Code (or scroll down the page to find Lat/Lon?)
  • Continue to the next page
  • Keep "Datum with associated ellipsoid"
  • Continue to the next page: bug appears "You must enter a value for Central Meridian" although values are inserted

See attached screenshot.

Attachments (2)

wingrass_location_wiz_bug.jpg (45.3 KB) - added by neteler 10 years ago.
location wizard bug
location_wizard.64.patch (630 bytes) - added by mmetz 10 years ago.
patch for location_wizard.py against 64

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by neteler

location wizard bug

comment:1 Changed 10 years ago by cmbarton

I just tried this and it works fine for me. No error if I duplicate your steps. You are doing this in 6.4 release branch right?

Michael

comment:2 Changed 10 years ago by neteler

Yes, I used the winGRASS package from the GRASS web site. The same was also confirmed by at least two other people (see mailing list). How can I debug this?

Markus

comment:3 Changed 10 years ago by cmbarton

Is it happening on Linux too, or only on Windows? It's not happening on the Mac.

Michael

comment:4 Changed 10 years ago by neteler

It is a Windows-only bug.

Markus

comment:5 Changed 10 years ago by hamish

Keywords: wingrass added

comment:6 Changed 10 years ago by cmbarton

OK. I'll take a look at the code with that in mind. I won't be able to test, but maybe I can see something

Changed 10 years ago by mmetz

Attachment: location_wizard.64.patch added

patch for location_wizard.py against 64

comment:7 Changed 10 years ago by mmetz

Attached patch works for me under Linux and Windows XP. The logic for this fix is that a default value was set and then got lost, therefore the error message, so it sets the default value again for all parameters that are not editable. Doesn't really make sense to me but works, and maybe it points into the right direction for a better fix.

Markus M

comment:8 in reply to:  7 Changed 10 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Status: newassigned

Replying to mmetz:

Attached patch works for me under Linux and Windows XP. The logic for this fix is that a default value was set and then got lost, therefore the error message, so it sets the default value again for all parameters that are not editable. Doesn't really make sense to me but works, and maybe it points into the right direction for a better fix.

right, committed in r40524. I am going to rewrite this part in devbr6 and trunk, so not backported. Martin

comment:9 Changed 10 years ago by martinl

Resolution: fixed
Status: assignedclosed

comment:10 Changed 10 years ago by Luigi Ponti

Resolution: fixed
Status: closedreopened

I am re-opening this because a similar problem happens with recent WinGRASS-6.4.SVN-r40650-1-Setup.exe (26-Jan-2010 03:47) on Windows 7. First report was on Windows Vista: please, see http://n2.nabble.com/Location-Wizard-Problem-tp4281871p4460300.html

Text input boxes for Central Parallel and Central Meridian are grayed, and show 0.0 preset answer with no way to modify it (you can put cursor in the text box and highlight 0.0 but there is no way to enter text).

Regards,

Luigi

comment:11 Changed 10 years ago by neteler

I think that the greyed out fields are correct (what to you want to change there?). But do you get the bug "You must enter a value for Central Meridian" although values are inserted?

Luigi: I tried it on a Japanese XP and it worked. Do you use the English or Italian version?

Markus

comment:12 Changed 10 years ago by hamish

0.0,0.0 is correct. you want 0 lat, 0 lon to be somewhere south of Ghana. Maybe for lat/lon we should hide those.

Hamish

comment:13 Changed 10 years ago by Luigi Ponti

Sorry for my ignorance, Hamish. That behavior (not being able to change greyed fields) has been reported as a problem on the mailing list (see link in my previous comment) so I thought it was a problem:

When I try to enter a Central Parallel or Central Meridian, nothing changes occur in the entry boxes. I can highlight the default zero values, but I am unable to change them.

However, I don't get the "You must enter a value for Central Meridian" bug, and the location gets created OK. Again I am on Win7 and no spaces in installation path -- maybe it is related to the latter?

I think I am using an Italian version: there is a mix of Italian and English language.

I apologize again for an incomplete report,

Luigi

comment:14 in reply to:  13 Changed 10 years ago by neteler

Replying to lponti:

Sorry for my ignorance, Hamish. That behavior (not being able to change greyed fields) has been reported as a problem on the mailing list (see link in my previous comment) so I thought it was a problem

To my knowledge the original issue was then you could not proceed on *some* platforms/computers. The fields are currently intentionally greyed out since it is not the definition of a custom projection (that's in another wizard section AFAIK).

However, I don't get the "You must enter a value for Central Meridian" bug, and the location gets created OK. Again I am on Win7 and no spaces in installation path -- maybe it is related to the latter?

So - everything fine on your's and my computer.

I think I am using an Italian version: there is a mix of Italian and English language.

[unrelated: because the translation isn't finished, support welcome]

Markus

comment:15 Changed 10 years ago by hamish

Resolution: fixed
Status: reopenedclosed

no reason to keep this one open AFAIK.

Note: See TracTickets for help on using tickets.