Opened 10 years ago

Closed 10 years ago

#847 closed defect (invalid)

v.out.ogr format=GMT ignores dsn=

Reported by: hamish Owned by: grass-dev@…
Priority: normal Milestone: 6.4.0
Component: Vector Version: svn-releasebranch64
Keywords: v.out.ogr, GMT Cc:
CPU: x86-32 Platform: Linux

Description

Hi,

I am just writing up a little vector export example for the wiki* and found that no matter what I set v.out.ogr's dsn= or layer= to, the output file name is always whatever the input= map name was with .gmt tacked onto the end of it.

using GDAL/OGR version 1.5.2 with grass 6.5.

[*] http://grass.osgeo.org/wiki/GMT#Example

?, Hamish

Change History (2)

comment:1 Changed 10 years ago by mmetz

Using GDAL/OGR version 1.6.0 with grass 6.5, I can confirm that for the dsn option, but not for the olayer option. If olayer=test is given, the output file is test.gmt. The dsn option should be the directory where the .gmt file is placed? Since the dsn option is working for other OGR output formats, this is probably a feature/bug of GDAL/OGR specific to the GMT format.

Markus M

comment:2 Changed 10 years ago by hamish

Resolution: invalid
Status: newclosed

ah, I was trying layer= not olayer=. User error.

this works:

v.out.ogr in=roads dsn=foo olayer=bar format=GMT type=line

(dsn= is ignored and bar.gmt is written)

I'm not sure of the semantics of dsn= and if it's ok to ignore it or not. if someone feels it's important feel free to reopen this bug.

Hamish

Note: See TracTickets for help on using tickets.