Opened 10 years ago

Closed 10 years ago

#806 closed defect (fixed)

WinGRASS: Problem with special characters (wxpython GUI)

Reported by: marmai Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: wxGUI Version: 6.4.0 RCs
Keywords: wingrass, umlaut charcter, german Cc:
CPU: Unspecified Platform: MSWindows XP

Description

In the latest winGRASS binary (standalone version: WinGRASS-6.4.0SVN-r39626-1-Setup.exe) there is a problem with the special characters in the German language ('Umlaute', e.g. ö,ä,ü): In the GUI windows that open at startup ('GRASS GIS Ebenen-Manager') everything is correct, but all GUIs for modules (started from within the wxpython GUI) have broken characters (all umlauts are broken; see attached file). This occured on W2k and XP, and can be reproduced.

Attachments (1)

grass_de_win.jpg (115.1 KB) - added by marmai 10 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by marmai

Attachment: grass_de_win.jpg added

comment:1 Changed 10 years ago by marmai

Component: defaultwxGUI

comment:2 Changed 10 years ago by cnielsen

Keywords: wingrass added
Priority: normalmajor

A french colleague of mine complained about the same issue. I'm not sure how to fix it although I may have missed a library when assembling the package.

It might help if you could tell me if this is the first version of wingrass you have had a problem with?

comment:3 in reply to:  2 Changed 10 years ago by marmai

Replying to cnielsen:

It might help if you could tell me if this is the first version of wingrass you have had a problem with?

I am not sure. I used the former wingrass versions, but I realized this problem the first time in this version. But I am not sure that this problem was not there in the older versions. Is it possible to get somewhere the old binary installer (for the old versions), then I will install a older version to check for this problem.

comment:4 in reply to:  2 Changed 10 years ago by marmai

Replying to cnielsen:

It might help if you could tell me if this is the first version of wingrass you have had a problem with?

I found an old binary in my downloads (WinGRASS-6.4.0SVN-r39271-1-Setup.exe downloaded 13th October 2009). I re-installed that version, and here is the same problem with the characters.

comment:5 Changed 10 years ago by neteler

We have done some modifications. Please check if the problem persists in the latest available winGRASS version.

comment:6 Changed 10 years ago by neteler

Resolution: duplicate
Status: newclosed

duplicate of #806

comment:7 Changed 10 years ago by neteler

Resolution: duplicate
Status: closedreopened

oops closed wrong report, sorry

comment:8 Changed 10 years ago by hamish

fwiw I see a "ü" in the $Date$ stamp of the AUTHORS file from the Help->About tab in the latest wingrass 6.4.0svn binary (r40456) on XP. (Presumably because this is due to the packager's locale.)

Hamish

comment:9 in reply to:  5 ; Changed 10 years ago by marmai

Replying to neteler:

We have done some modifications. Please check if the problem persists in the latest available winGRASS version.

Sorry, but there is still the problem with the German 'Umlaute' in the latest wingrass 6.4.0svn binary (r40456) on my machine (XP).

comment:10 in reply to:  9 ; Changed 10 years ago by hellik

Replying to marmai:

Replying to neteler:

We have done some modifications. Please check if the problem persists in the latest available winGRASS version.

Sorry, but there is still the problem with the German 'Umlaute' in the latest wingrass 6.4.0svn binary (r40456) on my machine (XP).

I can confirm on Grass64svn, but on Grass65svn all german 'Umlaute' are correctly displayed in the GUI

Helmut

comment:11 Changed 10 years ago by neteler

The file encoding is indentical:

file grass64/locale/po/*de.po grass65/locale/po/*de.po
grass64/locale/po/grasslibs_de.po: ISO-8859 English text
grass64/locale/po/grassmods_de.po: Lisp/Scheme program text
grass64/locale/po/grasstcl_de.po:  ISO-8859 English text
grass64/locale/po/grasswxpy_de.po: ISO-8859 English text
grass65/locale/po/grasslibs_de.po: ISO-8859 English text
grass65/locale/po/grassmods_de.po: Lisp/Scheme program text
grass65/locale/po/grasstcl_de.po:  ISO-8859 English text
grass65/locale/po/grasswxpy_de.po: ISO-8859 English text

Comparing gui/wxpython/gui_modules/menuform.py I see some SAX differences and p.get() and getNodeText() (which isn't used in 6.4) and in "class GUI" (SAX parsing no longer used). No idea if that's relevant.

Markus

comment:12 in reply to:  10 Changed 10 years ago by hellik

Replying to hellik:

Replying to marmai:

Replying to neteler:

We have done some modifications. Please check if the problem persists in the latest available winGRASS version.

Sorry, but there is still the problem with the German 'Umlaute' in the latest wingrass 6.4.0svn binary (r40456) on my machine (XP).

I can confirm on Grass64svn, but on Grass65svn all german 'Umlaute' are correctly displayed in the GUI

Helmut

tested on a fresh grass64svn-checkout, all german 'Umlaute' are correctly displayed in the GUI.

Helmut

comment:13 Changed 10 years ago by neteler

Resolution: fixed
Status: reopenedclosed

Martin has fixed it in r40553. Closing.

Note: See TracTickets for help on using tickets.