Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#779 closed defect (fixed)

v.digit doesn't work after moving to Ubuntu karmic

Reported by: lucacasagrande Owned by: grass-dev@…
Priority: normal Milestone: 6.4.0
Component: wxGUI Version: 6.4.0 RCs
Keywords: digit, wxgui Cc: martinl
CPU: x86-64 Platform: Linux

Description

Hello folks, I use 6.4 trunk built everyday but, after moving to Karmic, I have strange issues with v.digit and wx interface:

  • I can't edit existing layer because the menu is empty and there is just New vector map;
  • When moving vertex the feature dissapear untill I stop editing;

Another big problem is that setting the debug to level 3, freeze the GUI when open a new vector layer.

Using

Python 2.6.3 wx-config 2.8.10.1 SWIG 1.3.36

Thanks Luca

Change History (5)

comment:1 Changed 10 years ago by martinl

Cc: martinl added

comment:2 in reply to:  description Changed 10 years ago by hamish

Replying to lucacasagrande:

I use 6.4 trunk built everyday but, after moving to Karmic, I have strange issues with v.digit and wx interface:

I'm testing now on karmic with UbuntuGIS's 6.4.0rc5-3 package.

  • I can't edit existing layer because the menu is empty and

there is just New vector map;

I can't reproduce this. Are you sure the vector map is in the current mapset, and not via v.external. ie that it is not read-only?

  • When moving vertex the feature dissapear untill I stop editing;

I see the same thing, clicking on the eyeball brings it back though. Weird.

Another big problem is that setting the debug to level 3, freeze the GUI when open a new vector layer.

that's a known problem. stderr buffer can't cope.

Hamish

comment:3 Changed 7 years ago by neteler

Can we close this since it cannot be reproduced?

comment:4 Changed 7 years ago by annakrat

Resolution: fixed
Status: newclosed

Since there is no response, I am closing the ticket. Please reopen if needed.

comment:5 Changed 7 years ago by hamish

  • When moving vertex the feature dissapear untill I stop editing;

I see the same thing, clicking on the eyeball brings it back though. Weird.

that part was reproducible. Is it still the case?

Hamish

Note: See TracTickets for help on using tickets.