Opened 10 years ago

Closed 6 years ago

#762 closed enhancement (duplicate)

add menu location to help pages

Reported by: hamish Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: Docs Version: svn-trunk
Keywords: gui Cc:
CPU: All Platform: All

Description

Hi,

it might be a nice idea to add the XML menu location to help pages.

see http://grass.osgeo.org/gdp/grassmanuals/grass64_module_list.html

for an example. (built by tools/module_synopsis.sh and 'python menudata.py commands')

If menu position exists, it could be inserted between the auto-gen Usage header part and the description.html part. It could probably use menudata.py without the table produced by module_synopsis.sh (although the concept of saving the output in a text file would likely be faster than rerunning menudata.py for every module)

Hamish

Change History (1)

comment:1 Changed 6 years ago by neteler

Resolution: duplicate
Status: newclosed

Duplicate of trac #645

Note: See TracTickets for help on using tickets.