Opened 10 years ago

Closed 10 years ago

#678 closed defect (fixed)

wrong coordinates after zoom to named region

Reported by: mlennert Owned by: martinl
Priority: normal Milestone: 6.4.0
Component: wxGUI Version: 6.4.0 RCs
Keywords: named region Cc: grass-dev@…
CPU: Unspecified Platform: Linux

Description

Using the wxGUI digitizer, I have observed the following problem:

  • launch digitalisation of a new vector map
  • zoom to named region
  • digitize feature
  • feature is placed at wrong location, i.e. not in the area visible in the screen.

I can produce this with nc_spm_06 dataset:

  • create named region with:

North: 223800 South: 222810 West: 635560 East: 637070

  • launch wxgui digitizer and create new vector map
  • zoom to named region created above
  • draw a line across the screen

The line seems to disappear, but by zooming out you can see that it is placed elsewhere. It's bounding box as given by v.info is:

N: 222110 S: 221279 E: 637424 W: 637342

When I do not use a named region, but zoom by hand to the same area, I do not see the same problem.

Moritz

Change History (5)

comment:1 Changed 10 years ago by martinl

Cc: grass-dev@… added
Keywords: wxgui digitizer removed
Owner: changed from grass-dev@… to martinl
Status: newassigned
Summary: wxgui digitizer: wrong coordinates after zoom to named regionwrong coordinates after zoom to named region

The bug is not related to the vector digitizer. Hopefully fixed in r38317.

Martin

comment:2 in reply to:  1 ; Changed 10 years ago by mlennert

Replying to martinl:

The bug is not related to the vector digitizer.

No, apprently not, but it is easy to see there.

Hopefully fixed in r38317.

No, behaviour is different, but still weird:

  • zoom to named region
  • draw line : line ends seem to jump to outside the current window
  • zoom to current region: line is drawn somewhere else on the screen and much longer than it should be
  • zoom back to named region: line jumps back to normal length and more or less correct position.
  • zoom back to current region: line again jumps to other location and longer size
  • zoom by hand (with zoom box) after zoom to current region: zooms in but to a different area than the one indicated by the zoom box.

Something seems fundamentally wrong with the zoom management...

Moritz

comment:3 in reply to:  2 ; Changed 10 years ago by martinl

Replying to mlennert:

No, behaviour is different, but still weird:

  • zoom to named region
  • draw line : line ends seem to jump to outside the current window

seems to work for me, tested on relbr64 and trunk. What version, revision?

Martin

comment:4 in reply to:  3 ; Changed 10 years ago by martinl

Replying to martinl:

Replying to mlennert:

No, behaviour is different, but still weird:

  • zoom to named region
  • draw line : line ends seem to jump to outside the current window

seems to work for me, tested on relbr64 and trunk. What version, revision?

still relevant?

comment:5 in reply to:  4 Changed 10 years ago by mlennert

Resolution: fixed
Status: assignedclosed

Replying to martinl:

Replying to martinl:

Replying to mlennert:

No, behaviour is different, but still weird:

  • zoom to named region
  • draw line : line ends seem to jump to outside the current window

seems to work for me, tested on relbr64 and trunk. What version, revision?

still relevant?

Can't reproduce on fresh relbr64 on Ubuntu (also just updated from Intrepid to Jaunty, don't know if this might have solved it...). Will close for now.

Note: See TracTickets for help on using tickets.