Opened 10 years ago

Closed 10 years ago

#633 closed defect (fixed)

g.region: double free or corruption

Reported by: grass Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: Packaging Version: 6.4.0 RCs
Keywords: ubuntu Cc:
CPU: Unspecified Platform: Linux

Description (last modified by neteler)

when i run grass on ubuntu 9.04, install with launchpad depository adn les-ecjk i have this error ?

*** glibc detected *** g.region: double free or corruption (fasttop): 0x08c78ee0 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb77ba604]
/lib/tls/i686/cmov/libc.so.6(cfree+0x96)[0xb77bc5b6]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0xb6a61231]
/usr/lib/libstdc++.so.6(_ZNSs4_Rep10_M_destroyERKSaIcE+0x1d)[0xb6a3d9fd]
/usr/lib/libstdc++.so.6(_ZNSsD1Ev+0x51)[0xb6a3f3b1]
/lib/tls/i686/cmov/libc.so.6(__cxa_finalize+0xc1)[0xb7779f51]
/usr/local/lib/libgeos-3.0.3.so[0xb68bfd74]
/usr/local/lib/libgeos-3.0.3.so[0xb695f470]
/lib/ld-linux.so.2[0xb8086a73]

Change History (7)

comment:1 Changed 10 years ago by martinl

Summary: grass 6.4.0 RC 4g.region: double free or corruption

comment:2 Changed 10 years ago by hamish

Keywords: ubuntu added
Platform: UnspecifiedLinux

most likely a gdal/geos packaging problem from that repo

comment:3 Changed 10 years ago by hamish

Component: defaultPackaging

comment:4 Changed 10 years ago by hamish

I would note that this (appears to be) a packaging problem, not a code problem, so is not a blocker for the 6.4.0 release.

comment:6 Changed 10 years ago by hamish

Priority: criticalmajor

comment:7 Changed 10 years ago by hamish

Resolution: fixed
Status: newclosed

apparently fixed by latest unmixed UbuntuGIS packages.

Note: See TracTickets for help on using tickets.