Opened 12 years ago

Closed 9 years ago

#46 closed defect (fixed)

NVIZ fly mode broken on 64bit systems

Reported by: marisn Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: Tcl/Tk NVIZ Version: svn-trunk
Keywords: nviz Cc:
CPU: Unspecified Platform: Unspecified

Description

Fly mode in NVIZ is broken - when flying around, camera moves for some sec and then resets back to it's initial position.

Buggy on 64bit Ubuntu 7.10 and 64bit OpenSuSE 10.3 (both use Nvidia drivers) with GRASS 6.2.2, 6.2.3, current trunk. 32bit Gentoo (intel driver) with current trunk is not affected - it must be a 64bit problem.

Attachments (1)

togl_flythrough.c.diff (340 bytes) - added by kwasnicki 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by neteler

Confirmed on Mandriva 2007.1/64bit with NVIDIA.

comment:2 Changed 12 years ago by neteler

Confirmed on Mandriva 2008.0/64bit with NVIDIA.

comment:3 Changed 11 years ago by neteler

Component: defaultNVIZ

comment:4 Changed 9 years ago by marisn

CPU: Unspecified
Milestone: 6.4.06.4.1
Platform: Unspecified

Doesn't seem to make to 6.4.0.

Changed 9 years ago by kwasnicki

Attachment: togl_flythrough.c.diff added

comment:5 Changed 9 years ago by kwasnicki

looks like the problem is a float overflow in togl_flythrough.c:this_time() function. changing the (float) casts to (double) has fixed this on my 64bit slackware install.

diff attached... although not 100% sure if i created the diff patch properly, but this is just a one line change so i'm sure the code maintainer can replicate the necessary change if the diff doesn't work. ;-)

comment:6 in reply to:  5 Changed 9 years ago by hamish

Milestone: 6.4.16.4.0

Replying to kwasnicki:

diff attached... although not 100% sure if i created the diff patch properly, but this is just a one line change so i'm sure the code maintainer can replicate the necessary change if the diff doesn't work. ;-)

it ended up backwards, but it's just a 1 liner so no worries.

preferred method for creating patches is svn diff:

http://grass.osgeo.org/wiki/Bugs#Patches

Hamish

comment:7 Changed 9 years ago by marisn

Resolution: fixed
Status: newclosed

Fixed and backported to 6.4. r42592, r42593, r42594

Thanks to Ken Kwasnicki.

Note: See TracTickets for help on using tickets.