#4020 closed defect (wontfix)

r.in.lidar / v.in.lidar missing in Ubunutgis package

Reported by: sbl Owned by: grass-dev@…
Priority: normal Milestone:
Component: Packaging Version: unspecified
Keywords: Ubuntugis Cc:
CPU: All Platform: Linux

Description

Ubunutgis package for GRASS GIS 7.8 is build without liblas support, thus r.in.lidar / v.in.lidar modules are missing.

See: https://launchpadlibrarian.net/455539996/buildlog_ubuntu-bionic-amd64.grass_7.8.2-1~bionic1_BUILDING.txt.gz (and search for dh_auto_configure).

Note that dependencies (I guess liblas-dev) are not installed prior to configuration either.

See: https://launchpad.net/~ubuntugis/+archive/ubuntu/ubuntugis-unstable/+sourcepub/10345798/+listing-archive-extra for available liblas packages from UbuntuGIS unstable.

Change History (6)

comment:1 Changed 16 months ago by Bas Couwenberg

libLAS is deprecated and PDAL should be used instead, the libLAS website documents this:

As of 2018, libLAS has been replaced by the PDAL project and it is in hibernation or maintenance mode. libLAS does not provide support for LAS or LAZ 1.4, which PDAL does. PDAL also provides support for many more formats, the notion of PDAL pipelines, Python support, and has packages for OSGeo4W, Docker/Ubuntu/Alpine, and OSX Homebrew. Additionally, libLAS’ Python capabilities are much better expressed by the pure-Python laspy library, and if manipulating LAS data in Python is your ultimate desire, use that instead of libLAS.

The liblas package has been removed from Debian, and hence the grass package is only built with pdal. Because the grass package in UbuntuGIS uses the same source as Debian it likewise no longer supports liblas.

While liblas is still available in Ubuntu bionic, their next LTS (focal) won't have it either as it was removed in eoan.

Functionality provided by *.in.lidar should be ported to their *.in.pdal counterparts or port *.in.lidar to use PDAL instead of libLAS.

Last edited 16 months ago by Bas Couwenberg (previous) (diff)

comment:2 in reply to:  1 Changed 16 months ago by neteler

Replying to Bas Couwenberg:

Functionality provided by *.in.lidar should be ported to their *.in.pdal counterparts or port *.in.lidar to use PDAL instead of libLAS.

Yes.

See also https://github.com/OSGeo/grass/pull/61 ("WIP r.in.pdal - PDAL-based version of r.in.lidar") ... to be completed and extended to v.in.lidar.

comment:3 Changed 16 months ago by sbl

Yes, I agree that it would be important to port the functionality to PDAL.

But until that is done, and as long as liblas is available in UbuntuGIS (and here I am particularly talking about UbuntuGIS-unstable), I would love to see GRASS GIS build with liblas functionality. Importing LiDAR data would be dearly missed otherwise…

This is just a humble wish, I know you packagers have a lot to consider and I am very grateful for all your work!

comment:4 Changed 16 months ago by sbl

Most as a note to other readers and myself: v.in.pdal is already available in core at least since GRASS GIS 7.6 and r.in.pdal is available as an addon.

The manual for v.in.pdal however is not online (except for Ubuntu man pages https://manpages.ubuntu.com/manpages/disco/man1/v.in.pdal.1grass.html), making it less accessible.

Maybe pdal-support should be switched on for the build process that creates the online HTML manuals?

comment:5 in reply to:  4 Changed 16 months ago by neteler

Replying to sbl:

Maybe pdal-support should be switched on for the build process that creates the online HTML manuals?

Your wish is my command:

Last edited 16 months ago by neteler (previous) (diff)

comment:6 Changed 11 months ago by sbl

Resolution: wontfix
Status: newclosed

Closing this cause liblas is deprecated and pdal available...

Note: See TracTickets for help on using tickets.