Opened 4 years ago

Closed 10 months ago

#2865 closed defect (fixed)

Error when installing r.modis add-on and warning when starting grass

Reported by: veroandreo Owned by: grass-dev@…
Priority: normal Milestone: 7.0.7
Component: Addons Version: svn-trunk
Keywords: r.modis Cc:
CPU: x86-64 Platform: Linux

Description

Hi

I get the following error when installing the add-on r.modis.

GRASS 7.1.svn (latlong_wgs84):~ > g.extension r.modis
Fetching <r.modis> from GRASS GIS Addons repository (be patient)...
Compiling...
Traceback (most recent call last):
  File "/tmp/grass7-veroandreo-3549/tmpMJRoMB/r.modis/scripts/r.modis.download", line 94, in <module>
    from rmodislib import product
ImportError: No module named rmodislib
make[1]: *** [r.modis.download.tmp.html] Error 1
Traceback (most recent call last):
  File "/tmp/grass7-veroandreo-3549/tmpMJRoMB/r.modis/scripts/r.modis.import", line 100, in <module>
    from rmodislib import resampling, product, projection, get_proj
ImportError: No module named rmodislib
make[1]: *** [r.modis.import.tmp.html] Error 1
Installing...
/usr/bin/install: cannot stat ‘/tmp/grass7-veroandreo-3549/tmpMJRoMB/r.modis/docs/html/r.modis.download.html’: No such file or directory
make[1]: *** [install] Error 1
/usr/bin/install: cannot stat ‘/tmp/grass7-veroandreo-3549/tmpMJRoMB/r.modis/docs/html/r.modis.import.html’: No such file or directory
make[1]: *** [install] Error 1
Updating addons metadata file...
Installation of <r.modis> successfully finished

It seems to work fine though... I can load both r.modis.download and r.modis.import GUIs and do what I need to do. But, every time I start grass again, I get:

GRASS 7.1.svn (latlong_wgs84):~ > r.modis: Unable to fetch interface description for command 'r.modis'.

Details: [Errno 2] No such file or directory
WARNING: Some addons failed when loading. Please consider to update your addons by running 'g.extension.all -f'.

I fetch add-ons and all fine, but when re-start grass again... same WARNING as before. If I start grass without the GUI, there's no WARNING. If I remove r.modis add-on, I no longer get that error, of course. Don't know if both errors are related to the same thing or not. AFAIK, the same happens with the add-on r.green. Something is not recognized somehow.

I have some other add-ons installed (r.hants, for example), but no warning regarding any of them, just r.modis.

Attachments (1)

r_modis_no_manual_pages.png (192.4 KB) - added by Veroandreo 4 years ago.
no Manual page in GUIs of r.modis.*

Download all attachments as: .zip

Change History (21)

comment:1 in reply to:  description ; Changed 4 years ago by martinl

Replying to veroandreo:

I get the following error when installing the add-on r.modis.

I cannot reproduce this error in trunk. Please try to update your installation first.

comment:2 in reply to:  1 Changed 4 years ago by veroandreo

Replying to martinl:

Replying to veroandreo:

I get the following error when installing the add-on r.modis.

I cannot reproduce this error in trunk. Please try to update your installation first.

Hi, Martin. I just updated to r67570 and tried again. Exactly the same behavior.

comment:3 Changed 4 years ago by veroandreo

Hi again :)

I was exchanging emails with Luca regarding this issue, and he said he tried to fix the problem reported but (quoting him, hope he doesn't mind) "it seems bigger than expected. There is no bug in r.modis but the problem is in lib/python/script/task.py because it doesn't find r.modis (but the problem is there also with r.green)."

Maybe this helps?

Thanks a lot!

comment:4 in reply to:  3 ; Changed 4 years ago by martinl

Replying to veroandreo:

I was exchanging emails with Luca regarding this issue, and he said he tried to fix the problem reported but (quoting him, hope he doesn't mind) "it seems bigger than expected. There is no bug in r.modis but the problem is in lib/python/script/task.py because it doesn't find r.modis (but the problem is there also with r.green)."

here you speak about

GRASS 7.1.svn (latlong_wgs84):~ > r.modis: Unable to fetch interface
description for command 'r.modis'.

Details: [Errno 2] No such file or directory
WARNING: Some addons failed when loading. Please consider to update your
addons by running 'g.extension.all -f'.

I guess. It's harmless error which you can ignore. Yes of course it should be fixed. GUI is just trying to parse all addons and it's expecting that addon name is same with command (which is not true in the case of r.modis or r.green).

The real problem is compilation error which I was not able to reproduce. Martin

comment:5 in reply to:  4 Changed 4 years ago by veroandreo

Replying to martinl:

Replying to veroandreo:

I was exchanging emails with Luca regarding this issue, and he said he tried to fix the problem reported but (quoting him, hope he doesn't mind) "it seems bigger than expected. There is no bug in r.modis but the problem is in lib/python/script/task.py because it doesn't find r.modis (but the problem is there also with r.green)."

here you speak about

GRASS 7.1.svn (latlong_wgs84):~ > r.modis: Unable to fetch interface
description for command 'r.modis'.

Details: [Errno 2] No such file or directory
WARNING: Some addons failed when loading. Please consider to update your
addons by running 'g.extension.all -f'.

yes

I guess. It's harmless error which you can ignore. Yes of course it should be fixed. GUI is just trying to parse all addons and it's expecting that addon name is same with command (which is not true in the case of r.modis or r.green).

I understand, yes. As they are "groups" of addons, it should try to find all r.modis.* or r.green.* and not only r.modis/r.green.

The real problem is compilation error which I was not able to reproduce. Martin

I'm using r67612 now, tested again and the same error when installing. Is there anything I can do so you have more information to reproduce this error yourself? Or any other information I could report and that's relevant for this issue?

comment:6 Changed 4 years ago by neteler

Milestone: 7.0.3

Ticket retargeted after milestone closed

comment:7 Changed 4 years ago by neteler

Milestone: 7.0.4

Ticket retargeted after 7.0.3 milestone closed

comment:8 Changed 4 years ago by Veroandreo

Just an update:

Somewhere in the way between r67891 (the last ticket I opened) and r67965 that I'm using now, the warning when opening grass dissapeared but the other issue (the serious one) remains. I tried removing r.modis and installing back and here's the output:

GRASS 7.1.svn (latlong_wgs84):~ > g.extension r.modis
Fetching <r.modis> from GRASS GIS Addons repository (be patient)...
Compiling...
Traceback (most recent call last):
  File "/tmp/grass7-veroandreo-20256/tmp8pdvRv/r.modis/scripts/r.modis.download", line 94, in <module>
    from rmodislib import product
ImportError: No module named rmodislib
make[1]: *** [r.modis.download.tmp.html] Error 1
Traceback (most recent call last):
  File "/tmp/grass7-veroandreo-20256/tmp8pdvRv/r.modis/scripts/r.modis.import", line 100, in <module>
    from rmodislib import resampling, product, projection, get_proj
ImportError: No module named rmodislib
make[1]: *** [r.modis.import.tmp.html] Error 1
Installing...
/usr/bin/install: cannot stat ‘/tmp/grass7-veroandreo-20256/tmp8pdvRv/r.modis/docs/html/r.modis.download.html’: No such file or directory
make[1]: *** [install] Error 1
/usr/bin/install: cannot stat ‘/tmp/grass7-veroandreo-20256/tmp8pdvRv/r.modis/docs/html/r.modis.import.html’: No such file or directory
make[1]: *** [install] Error 1
Updating addons metadata file...
Installation of <r.modis> successfully finished

same as originally reported... the effect is that when I call modules' user interfaces they do not contain the "Manual page" (See attached .png). I do get help if I use nameofmodule --h

Changed 4 years ago by Veroandreo

Attachment: r_modis_no_manual_pages.png added

no Manual page in GUIs of r.modis.*

comment:9 Changed 4 years ago by martinl

Milestone: 7.0.47.0.5

comment:10 Changed 4 years ago by neteler

See also #2968 for a similar issue

comment:11 Changed 4 years ago by veroandreo

I tried removing all extensions, then removing ~./grass7/addons as in #2968 and g.extension r.modis still yields the same error as originally reported.

Fetching <r.modis> from GRASS GIS Addons repository (be patient)...
Compiling...
Traceback (most recent call last):
  File "/tmp/grass7-veroandreo-17563/tmpvAd7vx/r.modis/scrip
ts/r.modis.download", line 94, in <module>
    from rmodislib import product
ImportError: No module named rmodislib
make[1]: *** [r.modis.download.tmp.html] Error 1
Traceback (most recent call last):
  File "/tmp/grass7-veroandreo-17563/tmpvAd7vx/r.modis/scrip
ts/r.modis.import", line 100, in <module>
    from rmodislib import resampling, product, projection,
get_proj
ImportError: No module named rmodislib
make[1]: *** [r.modis.import.tmp.html] Error 1
Installing...
/usr/bin/install: cannot stat ‘/tmp/grass7-veroandreo-1756
3/tmpvAd7vx/r.modis/docs/html/r.modis.download.html’: No
such file or directory
make[1]: *** [install] Error 1
/usr/bin/install: cannot stat ‘/tmp/grass7-veroandreo-1756
3/tmpvAd7vx/r.modis/docs/html/r.modis.import.html’: No
such file or directory
make[1]: *** [install] Error 1
Updating addons metadata file...
Installation of <r.modis> successfully finished

At ~.grass7/addons/docs/html/ there's only r.modis.html and not r.modis.import.html nor r.modis.download.html, if that's of any help.

comment:12 in reply to:  11 Changed 4 years ago by lucadelu

Replying to veroandreo:

At ~.grass7/addons/docs/html/ there's only r.modis.html and not r.modis.import.html nor r.modis.download.html, if that's of any help.

They are missing also in the Addons documentation

comment:13 Changed 4 years ago by veroandreo

All the errors disappeared at some point (I'm now on r68704), and the gui's for r.modis.import and r.modis.download have their respective manual sections as expected.

Should this ticket be closed?

comment:14 Changed 3 years ago by martinl

There are still errors (tested with 7.0.5svn):

Fetching <r.modis> from GRASS-Addons SVN repository (be patient)...
Compiling...
Traceback (most recent call last):
  File "/tmp/tmp0yBF4p/r.modis/scripts/r.modis.download", line 94, in <module>
    from rmodislib import product
ImportError: No module named rmodislib
make[1]: *** [r.modis.download.tmp.html] Error 1
Traceback (most recent call last):
  File "/tmp/tmp0yBF4p/r.modis/scripts/r.modis.import", line 100, in <module>
    from rmodislib import resampling, product, projection, get_proj
ImportError: No module named rmodislib
make[1]: *** [r.modis.import.tmp.html] Error 1

comment:15 Changed 3 years ago by martinl

In 69221:

r.modis: attempt to fix compilation, see #2865

comment:16 Changed 3 years ago by martinl

In 69222:

r.modis: another attempt to fix compilation (order), see #2865

comment:17 Changed 3 years ago by martinl

Resolution: fixed
Status: newclosed

Fixed by r69221 and r69222.

comment:18 Changed 3 years ago by mlennert

Resolution: fixed
Status: closedreopened

Reopening, because using a freshly checked out trunk (r69714) and having erased the entire .grass7 directory, I still get the same error for r.modis:

> g.extension r.modis
Fetching <r.modis> from GRASS GIS Addons repository (be patient)...
Compiling...
Traceback (most recent call last):
  File "/tmp/grass7-mlennert-31361/tmpoyXxmW/r.modis/scripts/r.modis.download", line 94, in <module>
    from rmodislib import product
ImportError: No module named rmodislib
make[1]: *** [r.modis.download.tmp.html] Erreur 1
Traceback (most recent call last):
  File "/tmp/grass7-mlennert-31361/tmpoyXxmW/r.modis/scripts/r.modis.import", line 100, in <module>
    from rmodislib import resampling, product, projection, get_proj
ImportError: No module named rmodislib
make[1]: *** [r.modis.import.tmp.html] Erreur 1
Installing...
/usr/bin/install: impossible d'évaluer '/tmp/grass7-mlennert-31361/tmpoyXxmW/r.modis/docs/html/r.modis.download.html': Aucun fichier ou dossier de ce type
make[1]: *** [install] Erreur 1
/usr/bin/install: impossible d'évaluer '/tmp/grass7-mlennert-31361/tmpoyXxmW/r.modis/docs/html/r.modis.import.html': Aucun fichier ou dossier de ce type
make[1]: *** [install] Erreur 1
make: *** [installsubdirs] Erreur 2
ATTENTION: Installation failed, sorry. Please check above error messages.

comment:19 Changed 23 months ago by neteler

Milestone: 7.0.57.0.7

comment:20 Changed 10 months ago by veroandreo

Resolution: fixed
Status: reopenedclosed

I cannot reproduce the error anymore, closing.

Note: See TracTickets for help on using tickets.