Opened 6 years ago

Closed 6 years ago

#2828 closed defect (fixed)

t.rast.list gives error message if there are other mapsets with temp. database in search path

Reported by: pvanbosgeo Owned by: grass-dev@…
Priority: normal Milestone: 7.0.3
Component: Temporal Version: unspecified
Keywords: t.rast.list Cc:
CPU: Unspecified Platform: Linux

Description

If (on GRASS 7.1 master on Linux) I run t.rast.list in a mapset and I add another mapset to the search path with a temporal database, there is an error message that the database file does not exist. It still gives the correct output.

For example, if I run t.rast.list in the mapset CRU and the mapset Worldclim is in the search path, I get the following:

> t.rast.list -s input=prec where="strftime('%Y', start_time)='1902'" \
              columns=name
WARNING: Temporal database connection defined as:
         /media/HD2/Data/GRASSdb//Data_latlon/Worlclim/tgis/sqlite.db
         But database file does not exist.
WARNING: Temporal database connection defined as:
         /media/HD2/Data/GRASSdb//Data_latlon/Worlclim/tgis/sqlite.db
         But database file does not exist.
pre_y1902m1
pre_y1902m2
pre_y1902m3
pre_y1902m4
pre_y1902m5
pre_y1902m6
pre_y1902m7
pre_y1902m8
pre_y1902m9
pre_y1902m10
pre_y1902m11
pre_y1902m12

Change History (6)

comment:1 Changed 6 years ago by veroandreo

Milestone: 7.0.3

In grass71 r67001, I cannot reproduce this.

I have 3 mapsets with strds in the search path, but t.rast.list works as expected with no warning message:

GRASS 7.1.svn (latlong_wgs84):~ > g.mapsets -p
Accessible mapsets:
clorofila pruebas PERMANENT rrs_667
GRASS 7.1.svn (latlong_wgs84):~ > t.rast.list -s input=cla \
where="strftime('%Y', start_time)='2004'" columns=name
A20040012004008.L3m_8D_CHL_chlor_a_4km_arg
A20040092004016.L3m_8D_CHL_chlor_a_4km_arg
...

I've recompiled to r67160, and cannot reproduce there either, no warning. I'm on Fedora 22.

comment:2 Changed 6 years ago by neteler

Milestone: 7.0.3

Ticket retargeted after milestone closed

comment:3 Changed 6 years ago by neteler

Milestone: 7.0.4

Ticket retargeted after 7.0.3 milestone closed

comment:4 Changed 6 years ago by neteler

pvanbosgeo: still an issue with 7.0.3?

comment:5 Changed 6 years ago by pvanbosgeo

No, the problem has gone after the latest update

comment:6 Changed 6 years ago by neteler

Milestone: 7.0.47.0.3
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.