Opened 5 years ago

Closed 5 years ago

#2614 closed defect (fixed)

wxgui Output save fails with UnicodeEncodeError

Reported by: marisn Owned by: grass-dev@…
Priority: major Milestone: 7.0.1
Component: wxGUI Version: 7.0.0
Keywords: Cc:
CPU: Unspecified Platform: MSWindows Vista

Description

Steps to reproduce:

  • in Command console tab click on "save button"
  • choose any file where to save output
  • observe an error printed in command console:
    Traceback (most recent call last):
      File "C:\Program Files\GRASS GIS
    7.0.0\gui\wxpython\gui_core\goutput.py", line 387, in
    OnOutputSave
    
    output.write(text)
    UnicodeEncodeError
    :
    'ascii' codec can't encode character u'\u012b' in position
    273: ordinal not in range(128)
    

Priority is Major, as it creates 0 byte size files. I lost another error message due to not checking file contents after save :(

Change History (3)

comment:1 Changed 5 years ago by annakrat

Could you try r64809 in trunk?

comment:2 in reply to:  1 ; Changed 5 years ago by marisn

Replying to annakrat:

Could you try r64809 in trunk?

Yes, now it works just fine on my Vista VM and no bad side effects on GNU/Linux. Needs backporting.

comment:3 in reply to:  2 Changed 5 years ago by annakrat

Resolution: fixed
Status: newclosed

Replying to marisn:

Replying to annakrat:

Could you try r64809 in trunk?

Yes, now it works just fine on my Vista VM and no bad side effects on GNU/Linux. Needs backporting.

Done in r64817.

Note: See TracTickets for help on using tickets.