Opened 11 years ago

Closed 11 years ago

#231 closed defect (worksforme)

r.li.index in 6.3.1 svn doesn't work

Reported by: leolami Owned by: grass-dev@…
Priority: major Milestone: 6.4.0
Component: Raster Version: unspecified
Keywords: r.li Cc: niccolo@…, cavallini@…
CPU: Unspecified Platform: Linux

Description (last modified by neteler)

If i create a rigth configuration file with r.li.setup (es. moving window) and then I use r.li.shannon commands I have this error message:

GRASS 6.3.0svn (Toscana):~ > r.li.shannon map=uso_primavera_2005 conf=navacchio output=shannon --overwrite
Segmentation fault
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3613]: unable to open mask ... continue without!!!
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3612]: unable to open mask ... continue without!!!
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3611]: unable to open mask ... continue without!!!
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3610]: unable to open mask ... continue without!!!
GRASS 6.3.0svn (Toscana):~ > WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3609]: unable to open mask ... continue without!!!
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3608]: unable to open mask ... continue without!!!
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3607]: unable to open mask ... continue without!!!
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3606]: unable to open mask ... continue without!!!
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3605]: unable to open mask ... continue without!!!
WARNING: Can't open header file for [ in (null)]
CHILD[pid = 3604]: unable to open mask ... continue without!!!

Niccolò Rigacci, with the help of Markus Neteler, has recompiled GRASS and now it works but there is ever somethings of wrong.

Niccolo can you explain what did you do and where do you think the problem is?

Thank you Leonardo

Change History (3)

comment:1 Changed 11 years ago by leolami

Summary: r.li.index in 6.3.1 svn doesn't worlr.li.index in 6.3.1 svn doesn't work

comment:2 Changed 11 years ago by neteler

Description: modified (diff)

Please better define:

  • Platform:
  • CPU:
  • there is ever somethings of wrong.

I suppose it's a Debian Linux?

Markus

comment:3 Changed 11 years ago by neteler

Resolution: worksforme
Status: newclosed

No response, works for me... feel free to reopen with more information.

Markus

Note: See TracTickets for help on using tickets.