Opened 6 years ago

Closed 5 years ago

#2259 closed task (fixed)

some temporal modules have empty manual page

Reported by: martinl Owned by: grass-dev@…
Priority: blocker Milestone: 7.0.0
Component: Docs Version: svn-trunk
Keywords: temporal Cc:
CPU: Unspecified Platform: Unspecified

Description (last modified by martinl)

List of temporal modules with empty manual page:

  • t.rast.out.vtk
  • t.rast.to.rast3
  • t.rast3d.extract
  • t.rast3d.list
  • t.rast3d.mapcalc
  • t.rast3d.univar
  • t.remove
  • t.sample
  • t.support
  • t.topology
  • t.unregister
  • t.vect.db.select
  • t.vect.export
  • t.vect.extract
  • t.vect.import
  • t.vect.list
  • t.vect.observe.strds
  • t.vect.univar
  • t.vect.what.strds

At least minimum info (description, example) should be added before releasing GRASS7.

Change History (10)

comment:1 Changed 6 years ago by martinl

Description: modified (diff)

comment:2 Changed 6 years ago by huhabla

This is work in progress.

comment:3 Changed 5 years ago by martinl

Please could you update status, which manuals are still missing?

comment:4 Changed 5 years ago by wenzeslaus

Currently, the example in manual pages can use only generated data. The issue is that there is no official sample dataset for temporal data. Please see:

comment:5 in reply to:  4 ; Changed 5 years ago by martinl

Replying to wenzeslaus:

Currently, the example in manual pages can use only generated data. The issue is that there is no official sample dataset for temporal data. Please see:

to update status: http://grasswiki.osgeo.org/wiki/GRASS_Community_Sprint_Portland_2014#Manual_improvements

comment:6 in reply to:  5 Changed 5 years ago by sbl

Just updated status on: http://grasswiki.osgeo.org/wiki/GRASS_Community_Sprint_Portland_2014#Manual_improvements

Seems a mistake has slipped in into the manual page for t.rast3d.univar, the description is identical to t.rast3d.list / t.vect.list...

comment:7 Changed 5 years ago by neteler

Note: The page temporal/temporalintro.html needs an update for the default mapset in which the temporal DB is stored, as per #2258

comment:8 Changed 5 years ago by huhabla

List of empty manual pages was reduced in r62871 and r62874 to:

  • t.topology
  • t.vect.db.select
  • t.vect.extract
  • t.vect.list
  • t.vect.observe.strds
  • t.vect.univar
  • t.vect.what.strds

The introduction in temporal/temporalintro.html was updated in r62877 to reflect the mapset specific temporal database location.

comment:9 Changed 5 years ago by neteler

Luca Delucchi in collaboration with Soeren Gebbert updated the manual pages significantly in r63363.

Backported in r63771.

comment:10 in reply to:  9 Changed 5 years ago by lucadelu

Resolution: fixed
Status: newclosed

Replying to neteler:

Luca Delucchi in collaboration with Soeren Gebbert updated the manual pages significantly in r63363.

Backported in r63771.

With r63808 and r63809 all the temporal manual has description and at least an example. More small improvements are required but I'm going to close this ticket, reopen if needed.

Note: See TracTickets for help on using tickets.