Opened 6 years ago

Last modified 5 weeks ago

#2236 new task

REQUIREMENTS file not clear about compilation and priority

Reported by: wenzeslaus Owned by: grass-dev@…
Priority: trivial Milestone: 7.8.2
Component: Docs Version: svn-trunk
Keywords: compilation, requirements, dependencies Cc:
CPU: Unspecified Platform: Unspecified

Description

Th file source:grass/trunk/REQUIREMENTS.html list General requirements and Optional requirements however, this is not as useful as it could be.

For example, Python is in Optional requirements but you cannot build GRASS documentation and probably other things without it. Moreover, without Python you cannot use any module from scripts and temporal (which is not noted anywhere).

And in the same Optional requirements category there is R language and MySQL libraries which are really optional and not critical at all.

By the way, R is referred as just R at their website (http://www.r-project.org/) and other places. Description of a package in Ubuntu says GNU R and R. The project for development of this software is sometimes referred as R project (note the lower p), most notably the URL of the web site. However, since R is too short, sometimes, R * environment, R * system or, previously mentioned, GNU R are used.

Change History (12)

comment:1 Changed 6 years ago by hamish

Hi,

Python now moved to required section in r59504. Also I changed 'R language' to 'R Statistics', so it will be understandable even to people who haven't heard of it before.

what's the story with XDR + MS Windows? is it mandatory/what provides it there?

Hamish

comment:2 in reply to:  1 Changed 6 years ago by glynn

Replying to hamish:

what's the story with XDR + MS Windows? is it mandatory/what provides it there?

XDR is no longer a dependency in 7.0. libgis provides XDR functions (they currently only work on systems where floating-point uses IEEE-754 representation, which is roughly everything except for Cray and Vax).

comment:3 Changed 6 years ago by neteler

REQUIREMENTS.html updated for XDR in r59854 and r59855.

comment:4 Changed 4 years ago by martinl

Milestone: 7.0.07.0.5

comment:5 Changed 3 years ago by martinl

Can we close this ticket?

comment:6 Changed 3 years ago by wenzeslaus

There was several improvements in last two years including Python. An overall review won't harm I guess.

https://trac.osgeo.org/grass/log/grass/trunk/REQUIREMENTS.html

R is still strange. There is no such thing as R Statistics. We also might need a category Recommended (in scale Dependency - Optional - Recommended) because now R at the same level with C++ which is needed e.g. for r.viewshed.

comment:7 Changed 3 years ago by neteler

Milestone: 7.0.57.0.6

comment:8 Changed 22 months ago by neteler

Milestone: 7.0.67.0.7

comment:9 Changed 8 months ago by martinl

Still relevant?

comment:10 Changed 7 months ago by sbl

Milestone: 7.0.77.8.0

Bumping it to 7.8

comment:11 Changed 3 months ago by neteler

Milestone: 7.8.07.8.1

Ticket retargeted after milestone closed

comment:12 Changed 5 weeks ago by neteler

Milestone: 7.8.17.8.2

Ticket retargeted after milestone closed

Note: See TracTickets for help on using tickets.