Opened 6 years ago

Closed 4 years ago

#2212 closed defect (fixed)

Map display fails to display top layer if 29 or more layers are in the list

Reported by: bhlevca Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: svn-trunk
Keywords: display Cc:
CPU: x86-64 Platform: Linux

Description

I created 48 raster layers for an animation. The top layer is the land boundary and all subsequent layers are time interpolated rasters (evolution of temperature in time)

I activated the fist layer (land boundary layer always on top) + and one by one (kept only one temp map active display) therefore I has active for display on the mam only 2 layers at a time: top + one of the 2nd , 3rd, ... etc until 48.

By the time I reached the 29 layer the land boundary in not displayed anymore. Therefore if between the 2 layers in the list are 29 or more items the first layer (top layer) is not displayed.

I tried this several times and it is reproducible.

The workaround was to move the land boundary layer after the 29 position in the list and I could display the rest of the layers on the map for saving to disk.

Not catastrophic bug, but I think it needs to be addressed

Change History (4)

comment:1 Changed 6 years ago by hamish

Hi,

which tool are you using to make the animation? just individual save screen as image?

(so is it related to just the layer list, or one of the animation tools?)

see also http://grasswiki.osgeo.org/wiki/Movies

thanks, Hamish

comment:2 in reply to:  1 Changed 6 years ago by bhlevca

Hi

I am saving maps as PNG and animate with mencoder. I believe that the animation tool you are pointing tool deals onlu with individual layers. I need to animate multiple layers. Saving maps from the display manager as image files just does that.

Now irrespective of what I am using the bug is valid. If two layers in a list are separated by more than 29 items the display manager gets confused

Thanks Bogdan

comment:3 Changed 6 years ago by wenzeslaus

I don't have exact numbers but I can confirm that I experienced something like that several times.

And if you are doing some animations, make sure that you check G7:g.gui.animation. You can add there multiple layers (e.g. animate elevation raster and contours with static boundary layer at the same). Other links: https://www.youtube.com/watch?v=Pi1ESk9iPwk, http://grasswiki.osgeo.org/wiki/WxGUI_Animation_Tool

comment:4 Changed 4 years ago by annakrat

Component: DefaultwxGUI
Resolution: fixed
Status: newclosed

I think this has been solved some time ago. If not, please reopen the ticket.

Note: See TracTickets for help on using tickets.