Opened 6 years ago

Closed 3 years ago

#2178 closed defect (worksforme)

No polygon fill when using the png display driver

Reported by: pvanbosgeo Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: Display Version: unspecified
Keywords: pngdriver Cc:
CPU: Unspecified Platform: Unspecified

Description

When using png display driver, only polygon boundaries are shown, i.e., they are shown without fill. Using the cairo display driver, things work as expected.

Attachments (1)

GRASStest.zip (159.0 KB) - added by pvanbosgeo 6 years ago.
GRASS GIS database with the nc_state layer from the North Carolina sample data set

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by neteler

Keywords: pngdriver added

Could you please post a reproducable example here with the North Carolina sample dataset? And which Operating system?

Changed 6 years ago by pvanbosgeo

Attachment: GRASStest.zip added

GRASS GIS database with the nc_state layer from the North Carolina sample data set

comment:2 Changed 6 years ago by pvanbosgeo

I am running on Linux (Ubuntu 13.10). I just tried the North Carolina sample dataset, but that works fine.

Layers from one of my mapsets copied to the North Carolina dataset (using v.proj) display fine.

The other way around, layers from the North Carolina dataset copied to my location/mapset (again, using v.proj) do not display correctly (missing fill). See the attached GRASS dataset (GRASStest) with in the location latlon, mapset PERMANENT one layer nc_state copied from the North Carolina dataset.

comment:3 Changed 6 years ago by hamish

Summary: No polygon fill when using the pnv display driverNo polygon fill when using the png display driver

comment:4 Changed 3 years ago by martinl

Milestone: 7.0.07.0.5

comment:5 Changed 3 years ago by martinl

Resolution: worksforme
Status: newclosed

Tested with GRASS 7.0.5svn, it works. Closing. Feel free to reopen if needed.

Note: See TracTickets for help on using tickets.