Opened 6 years ago

Last modified 10 months ago

#2117 reopened defect

GRASS 7: NVIZ: Transparency error for constant surface in

Reported by: richardc Owned by: grass-dev@…
Priority: normal Milestone: 7.4.5
Component: wxGUI Version: svn-trunk
Keywords: NVIZ Cc:
CPU: x86-32 Platform: Linux

Description

Hi,

I notice that setting the constant surface transparency to any value other that zero, causes the constant surface to disappear above a raster layer. The surface remains visible surrounding the image. Only if the constant surface is given a transparency of zero (i.e., 100% opaque) is it possible to position above a raster image.

GRASS 7.0.svn (version 57721) Linux Mint 13 (ubuntu precise)

Richard

Change History (10)

comment:1 Changed 6 years ago by hamish

see also #2175, since it is also seen from the command line with m.nviz.image, the root cause seems to be in the ogsf library functions.

what happens is the transparent planar surface is rendered first, then the DEM is rendered over the top of it, instead of the DEM being rendered first then the the transparent planar surface rendered through it.

Similar behaviour is also seen for #2175 in devbr6, and perhaps 6.4 too (untested).

Hamish

comment:2 Changed 4 years ago by martinl

Milestone: 7.0.07.0.5

comment:3 Changed 3 years ago by martinl

Resolution: worksforme
Status: newclosed

No activity last 3 years, closing, feel free to reopen if needed.

comment:4 Changed 3 years ago by annakrat

Milestone: 7.0.57.3.0
Resolution: worksforme
Status: closedreopened

Still valid

comment:5 Changed 3 years ago by martinl

Milestone: 7.3.07.4.0

Milestone renamed

comment:6 Changed 22 months ago by neteler

Milestone: 7.4.07.4.1

Ticket retargeted after milestone closed

comment:7 Changed 17 months ago by neteler

Milestone: 7.4.17.4.2

comment:8 Changed 13 months ago by neteler

Milestone: 7.4.27.4.3

Ticket retargeted after milestone closed

comment:9 Changed 11 months ago by martinl

Milestone: 7.4.37.4.4

Bump milestone to 7.4.4

comment:10 Changed 10 months ago by neteler

Milestone: 7.4.47.4.5

Ticket retargeted after milestone closed

Note: See TracTickets for help on using tickets.