Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1949 closed defect (fixed)

module gui doesn't release if no map display window

Reported by: hamish Owned by: grass-dev@…
Priority: normal Milestone: 6.4.3
Component: wxGUI Version: svn-develbranch6
Keywords: module guis Cc:
CPU: All Platform: All

Description

Hi,

(wingrass 6.5svn nightly build r55955)

I had closed the Map Display window since I was just testing data import and looking at processing reports.

When running a module in wxGUI (desktop icon startup) the control buttons that are greyed out during the run never come back.

test module: g.region from the menu, select -p flag from the Print tab and [Run]

traceback error printed to the output tab:

Traceback (most recent call last):
  File "C:\Program Files\GRASS GIS
6.5.svn\etc\wxpython\gui_core\goutput.py", line 867, in
OnCmdDone

event.onDone(cmd = event.cmd, returncode = event.returncode)
  File "C:\Program Files\GRASS GIS
6.5.svn\etc\wxpython\gui_core\forms.py", line 595, in OnDone

display = self.parent.GetLayerTree().GetMapDisplay()
AttributeError
:
'NoneType' object has no attribute 'GetMapDisplay'

tested and the same happens in Linux.

thanks, Hamish

Change History (7)

comment:1 in reply to:  description ; Changed 7 years ago by annakrat

Replying to hamish:

When running a module in wxGUI (desktop icon startup) the control buttons that are greyed out during the run never come back.

What exactly do you mean with control buttons?

test module: g.region from the menu, select -p flag from the Print tab and [Run]

traceback error printed to the output tab:

Traceback (most recent call last):

display = self.parent.GetLayerTree().GetMapDisplay()
AttributeError
:
'NoneType' object has no attribute 'GetMapDisplay'

should be fixed in r55989.

comment:2 in reply to:  1 Changed 7 years ago by hamish

Replying to annakrat:

should be fixed in r55989.

Hi,

it works now, nice.

(please always commit to the dev branches first for testing, then backport once testing is confirmed :). otherwise it gets hard to untangle later since you can't trust the devbranch is newer, bulk backports erase previous fixes, last minute typos make it into the rel.br.., etc. all have happened in the past)

thanks, Hamish

comment:3 in reply to:  1 ; Changed 7 years ago by hamish

Replying to annakrat:

Replying to hamish:

When running a module in wxGUI (desktop icon startup) the control buttons that are greyed out during the run never come back.

What exactly do you mean with control buttons?

[Close] [Run] [Copy] [Help] at the bottom of the module gui window

comment:4 in reply to:  3 ; Changed 7 years ago by annakrat

Replying to hamish:

What exactly do you mean with control buttons?

[Close] [Run] [Copy] [Help] at the bottom of the module gui window

Please test, it should be working now.

comment:5 in reply to:  4 ; Changed 7 years ago by hamish

Resolution: fixed
Status: newclosed

Replying to annakrat:

Please test, it should be working now.

(I did, see comment:2)

does it need to be merged to trunk?

comment:6 in reply to:  5 ; Changed 7 years ago by annakrat

Replying to hamish:

Replying to annakrat:

Please test, it should be working now.

(I did, see comment:2)

Another fix was needed.

does it need to be merged to trunk?

no, it's rewritten there, I tested it and it's working.

comment:7 in reply to:  6 Changed 7 years ago by hamish

Replying to annakrat:

Replying to hamish:

Replying to annakrat:

Please test, it should be working now.

(I did, see comment:2)

Another fix was needed.

ok, well it worked for me then, and I just retested in latest wingrass 6.4.3svn nightly now and works again, so all's well.

does it need to be merged to trunk?

no, it's rewritten there, I tested it and it's working.

ok, I was just noticing the lack-of-change.

thanks, Hamish

Note: See TracTickets for help on using tickets.