Opened 7 years ago

Closed 6 years ago

#1872 closed defect (fixed)

r.in.wms doesn't work on Windows

Reported by: martinl Owned by: grass-dev@…
Priority: major Milestone: 7.0.0
Component: Raster Version: svn-trunk
Keywords: r.in.wms Cc:
CPU: Unspecified Platform: MSWindows 2K

Description

Using latest WinGRASS 7 (OSGeo4w) r.in.wms refuse to work.

r.in.wms url=http://irs.gis-lab.info layers=osm output=osm format=png           
ERROR: Unable to determine region, m.proj failed

Change History (9)

comment:1 Changed 7 years ago by martinl

Version: unspecifiedsvn-trunk

comment:2 Changed 6 years ago by neteler

Is this still the case (I also wonder why a single WMS module can have a "critical" level)?

comment:3 Changed 6 years ago by hamish

it is worth re-testing since the script called from within another script winggrass bug was recently fixed. that was for .bat wrappers in grass6 though, so may not apply to trunk.

also for locations using a grid file for the datum transform note the bug that there is no way to pass the path to a NTv2 grid filename to cs2cs if the path has a space in it, which can cause m.proj to fail. we should probably submit a quoting patch to proj4 to get that eventually fixed.

... and a reminder that r.in.wms2.py does not run from grass6 addons, still needs more porting work done on it.

Hamish

comment:4 in reply to:  2 Changed 6 years ago by mlennert

Priority: criticalmajor

Replying to neteler:

Is this still the case (I also wonder why a single WMS module can have a "critical" level)?

I agree. Downgrading to major.

Moritz

comment:5 Changed 6 years ago by mlennert

Is this bug still an issue ?

comment:6 Changed 6 years ago by hamish

I have not tested script-within-a-script in WinGrass7 or r.in.wms.py there to see if m.proj is working with/without a NTv2 grid file, but afaik issues as discussed in comment:3 remain.

regards, Hamish

comment:7 Changed 6 years ago by wenzeslaus

In order to keep this ticket focused:

Note that script-within-a-scrip for standalone WinGRASS trunk is subject of #2150 but a workaround is now applied. If this was the cause, r.in.wms should work now.

Note also that whether m.proj is working with/without a NTv2 grid file can test only somebody who understands what it is (e.g. I cannot not). Is this MS Windows specific as this ticket is? Is this what the message suggests? Perhaps the message should be changed to give more details.

For GRASS 6, there is a separate ticket for r.in.wms2, #2010 and ticket #820 for r.in.wms.

comment:8 Changed 6 years ago by turek

r59335 should fix it.

comment:9 in reply to:  8 Changed 6 years ago by martinl

Resolution: fixed
Status: newclosed

Replying to turek:

r59335 should fix it.

confirmed, in r59352 I fixed also remaining bug related to debug messages. Thanks, closing the ticket.

Note: See TracTickets for help on using tickets.