Opened 7 years ago

Closed 7 years ago

#1845 closed defect (fixed)

v.buffer: strange result for lines

Reported by: martinl Owned by: grass-dev@…
Priority: critical Milestone: 7.0.0
Component: Vector Version: svn-trunk
Keywords: v.buffer, lines, 3D input Cc:
CPU: x86-64 Platform: Linux

Description (last modified by martinl)

Sample data attached: attachment:silnice.txt

Buffer 1000m - OK (attachment:v_buffer_1000.png)

v.buffer input=silnice output=silnice1000 distance=1000

Buffer 100m (using GEOS) - surprisingly wrong (attachment:v_buffer_100_geos.png)

v.buffer input=silnice output=silnice100 distance=100

Buffer 100m (using GRASS) - wrong - not surprisingly (attachment:v_buffer_100_grass.png)

export GRASS_VECTOR_BUFFER=1
v.buffer input=silnice output=silnice100 distance=100

Attachments (5)

silnice.txt (79.1 KB) - added by martinl 7 years ago.
sample data
v_buffer_1000.png (55.7 KB) - added by martinl 7 years ago.
Buffer 1000m
v_buffer_100_grass.png (51.0 KB) - added by martinl 7 years ago.
Buffer 100m (GRASS)
v_buffer_100_geos.png (46.7 KB) - added by martinl 7 years ago.
Buffer 100m (GEOS)
silnice.pack (22.5 KB) - added by martinl 7 years ago.
original binary map

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by martinl

Attachment: silnice.txt added

sample data

Changed 7 years ago by martinl

Attachment: v_buffer_1000.png added

Buffer 1000m

Changed 7 years ago by martinl

Attachment: v_buffer_100_grass.png added

Buffer 100m (GRASS)

Changed 7 years ago by martinl

Attachment: v_buffer_100_geos.png added

Buffer 100m (GEOS)

comment:1 Changed 7 years ago by martinl

Description: modified (diff)
Priority: normalcritical

comment:2 in reply to:  description ; Changed 7 years ago by mmetz

Replying to martinl:

Sample data attached: attachment:silnice.txt

Buffer 100m (using GEOS) - surprisingly wrong (attachment:v_buffer_100_geos.png)

Works for me. Do you have any changes in your local copy?

v.buffer input=silnice output=silnice100 distance=100

Buffer 100m (using GRASS) - wrong - not surprisingly (attachment:v_buffer_100_grass.png)

export GRASS_VECTOR_BUFFER=1
v.buffer input=silnice output=silnice100 distance=100

Looks better for me, but still with errors.

I'm using GEOS-3.3.6.

Markus M

comment:3 in reply to:  2 ; Changed 7 years ago by martinl

Replying to mmetz:

Works for me. Do you have any changes in your local copy?

hm, it fails only with original binary map (attachment:silnice.pack), not with imported ascii map.

Changed 7 years ago by martinl

Attachment: silnice.pack added

original binary map

comment:4 in reply to:  3 ; Changed 7 years ago by mmetz

Replying to martinl:

Replying to mmetz:

Works for me. Do you have any changes in your local copy?

hm, it fails only with original binary map (attachment:silnice.pack), not with imported ascii map.

The original binary map is 3D, the imported ascii map is 2D. I guess one of the cleaning tools does not work with 3D output, even though v.buffer creates 2D output. Strange.

Markus M

comment:5 in reply to:  4 Changed 7 years ago by martinl

Keywords: 3D input added

Replying to mmetz:

The original binary map is 3D, the imported ascii map is 2D. I guess one of the cleaning tools does not work with 3D output, even though v.buffer creates 2D output. Strange.

I overlooked it, good point.

comment:6 Changed 7 years ago by mmetz

Should be fixed in r54529.

Markus M

comment:7 in reply to:  6 Changed 7 years ago by martinl

Resolution: fixed
Status: newclosed

Replying to mmetz:

Should be fixed in r54529.

Confirmed, thanks for super-quick fix.

Note: See TracTickets for help on using tickets.