Opened 7 years ago

Closed 7 years ago

#1806 closed defect (fixed)

interrupting a command with CTRL+c closes wxGUI

Reported by: msieczka Owned by: grass-dev@…
Priority: critical Milestone: 6.4.3
Component: wxGUI Version: 6.4.3 RCs
Keywords: Cc: grass-dev@…
CPU: x86-64 Platform: MSWindows 7

Description

  1. start "GRASS GIS 6.4.3RC1 GUI with MSYS"
  1. press CTRL+c on GRASS MSYS at any time = wxGUI closes

Change History (3)

comment:1 Changed 7 years ago by hamish

pressing ctrl-C at the rxvt command prompt, or in the gui window?

I guess the scenario is the user trying to copy some text to the clipboard?

Hamish

comment:2 Changed 7 years ago by hamish

I can't reproduce this on Window7 with yesterday's nightly 6.4.3svn build.

For me ctrl-c acts like it always does at a bash prompt.

I see a couple other problems with the grass terminal prompt and regular grass wxgui and a dosbox, but I'll file those as other bugs, no problem with grass + msys.

Hamish

comment:3 Changed 7 years ago by msieczka

Resolution: fixed
Status: newclosed

pressing ctrl-C at the rxvt command prompt, or in the gui window?

MSYS command prompt.

I guess the scenario is the user trying to copy some text to the clipboard?

It was the user trying to interrupt a GRASS command started on the MSYS command line.

I can't reproduce this on Window7 with yesterday's nightly 6.4.3svn build.

Confirmed. Closing ticket, not knowing what the fix was though.

Note: See TracTickets for help on using tickets.