Opened 7 years ago

Closed 7 years ago

#1762 closed defect (duplicate)

g.extension fails again on Mac

Reported by: cmbarton Owned by: grass-dev@…
Priority: major Milestone: 6.4.3
Component: Addons Version: svn-releasebranch64
Keywords: Cc:
CPU: OSX/Intel Platform: MacOSX

Description

I just tried g.extension with GRASS 7 r53330 and got a weird error.

(Tue Oct  9 09:16:50 2012)                                                      
g.extension extension=g.copyall operation=add                                   
Fetching <g.copyall> from GRASS-Addons SVN (be patient)...
Compiling...
ERROR: Variable 'LOCATION_NAME' not set
make: *** [g.copyall.tmp.html] Error 1
ERROR: Compilation failed, sorry. Please check above error messages.
(Tue Oct  9 09:16:53 2012) Command finished (2 sec)                             

But when I run g.gisenv...

GRASS 7.0.svn (nc_spm_08):~ > g.gisenv
MAPSET=spatialtech2012
GISDBASE=/Users/Shared/grassdata
LOCATION_NAME=nc_spm_08
GUI=wxpython
GRASS_GUI=wxpython

Any ideas? (don't know what "component" to list for this)

Michael

Change History (7)

comment:1 Changed 7 years ago by annakrat

For me it's working just fine (on Ubuntu, latest revision).

comment:2 Changed 7 years ago by cmbarton

Component: DefaultAddons
CPU: UnspecifiedOSX/Intel
Milestone: 7.0.06.4.3
Platform: UnspecifiedMacOSX
Priority: normalmajor
Version: unspecifiedsvn-releasebranch64

I just tried g.extension for the first time in awhile in GRASS 6.4.3 release branch.

It is broken on the Mac at least. I've seen notices that it is broken on Windows. This may be the same problem. But I'm assuming not for the moment. Here the error. GRASS_ADDON_PATH is correct. The problem is somewhere else. So far, I've tried r.xtent, r.out.kml, and r.prominence. I KNOW that r.prominence used to compile under GRASS 6 at least in the past couple years. g.extension has always been on the buggy side with the mac. But it was working more or less the last time I tried it a year or so back.

Here is the error for r.xtent

(Sun Feb 24 14:32:13 2013)                                                      
g.extension.py extension=r.xtent operation=add                                  
WARNING: GRASS_ADDON_PATH has more items, using first defined - '/Users/cmbarton/Library/GRASS/6.4/Modules/bin'
Fetching <r.xtent> from GRASS-Addons SVN (be patient)...
Compiling...
/Applications/GRASS/GRASS-6.4.app/Contents/MacOS/include/Mak
e/Grass.make:423: warning: overriding commands for target `/
Users/Shared/grassdata/Global_latlon/Spain_sites_SAA2012/.tm
p/Michaels-MacBook-Air.local/37744.0/r.xtent/bin'
/Applications/GRASS/GRASS-6.4.app/Contents/MacOS/include/Mak
e/Grass.make:414: warning: ignoring old commands for target 
`/Users/Shared/grassdata/Global_latlon/Spain_sites_SAA2012/.
tmp/Michaels-MacBook-Air.local/37744.0/r.xtent/bin'
/Applications/GRASS/GRASS-6.4.app/Contents/MacOS/include/Mak
e/Module.make:25: warning: overriding commands for target
`install'
/Applications/GRASS/GRASS-6.4.app/Contents/MacOS/include/Mak
e/Rules.make:99: warning: ignoring old commands for target
`install'
at_exit_funcs.c:30:23: error: grass/gis.h: No such file or
directory
at_exit_funcs.c:31:27: error: grass/glocale.h: No such file
or directory
at_exit_funcs.c:30:23: error: grass/gis.h: No such file or
directory
at_exit_funcs.c:31:27: error: grass/glocale.h: No such file
or directory
lipo: can't figure out the architecture type of: /var/folder
s/65/pp9w7z0d1mj502pj8hhl7vfw0000gn/T//ccw30r7o.out
make: *** [OBJ.x86_64-apple-darwin12.2.0/at_exit_funcs.o]
Error 1
ERROR: Compilation failed, sorry. Please check above error messages.
(Sun Feb 24 14:32:21 2013) Command finished (8 sec)      

comment:3 in reply to:  2 Changed 7 years ago by hellik

Replying to cmbarton: [...]

I've seen notices that it is broken on Windows. This may be the same problem. But I'm assuming not for the moment.

in windows precompilded binaries/scripts are used.

Helmut

comment:4 Changed 7 years ago by cmbarton

So apparently not related then.

Michael

comment:5 Changed 7 years ago by hamish

Summary: g.extension fails againg.extension fails again on Mac

Hi,

Was this the shell script version from the command line, or the python version of g.extension from the wxGUI?

Does installing a shell or python script addon (as opposed to a compiled C code one) work?

Is Xcode installed?

Do newer versions of Xcode include GNU make along with LLVM?

Does the current MacGrass? package ship the $GISBASE/include/ headers & matching paths in $GISBASE/include/Make/*.make?

thanks, Hamish

comment:6 Changed 7 years ago by hamish

see also #854

comment:7 Changed 7 years ago by hamish

Resolution: duplicate
Status: newclosed

see questions in comment:5.

continued in #854.

Hamish

Note: See TracTickets for help on using tickets.