Opened 7 years ago

Closed 7 years ago

#1737 closed defect (duplicate)

Windows users cannot access manage table controls in attribute manager

Reported by: cmbarton Owned by: grass-dev@…
Priority: critical Milestone: 6.4.3
Component: wxGUI Version: svn-releasebranch64
Keywords: wingrass, attribute table manager Cc:
CPU: Unspecified Platform: MSWindows 7

Description

People using Windows cannot access the table controls in the manage table page of the attribute table manager. This is broken for GRASS 6.4.2 also, but a fix was implemented in GRASS 7 in February or March of this year. I thought it was backported, but I guess it was not. This needs to be done. AFAICT, this affects all Windows versions.

Change History (15)

comment:1 Changed 7 years ago by cmbarton

Component: DefaultwxGUI

comment:2 Changed 7 years ago by marisn

Michael, isn't this dupe of #1614 ? It was fixed for 6.4.3.

comment:3 Changed 7 years ago by cmbarton

Hmm. I couldn't find the other one for some reason. Maybe it is a dupe, but apparently it is not fixed--unless the recent windows snapshot (a week or 2 back) doesn't include this fix.

Michael

comment:4 Changed 7 years ago by marisn

Michael, please, can You specify what exactly is failing? Error messages?

On MS Vista today's (19. 09) 6.4.x SVN nightly is failing to open attribute table with error (can't copy it): 'columns' is not recognized as internal or external command... And then it still fails as per #1614

Strange...

comment:5 in reply to:  4 Changed 7 years ago by mlennert

Replying to marisn:

Michael, please, can You specify what exactly is failing? Error messages?

On MS Vista today's (19. 09) 6.4.x SVN nightly is failing to open attribute table with error (can't copy it): 'columns' is not recognized as internal or external command... And then it still fails as per #1614

Strange...

I saw the same error message with two students working on GRASS 6.4.3svn installed via osgeo4w ten days ago. I haven't had the time to follow that up, but if since Maris confirms, this seems to be a serious issue. I would propose to make this (or #1614) a blocker for 6.4.3.

Moritz

comment:6 in reply to:  4 ; Changed 7 years ago by hellik

Replying to marisn:

Michael, please, can You specify what exactly is failing? Error messages?

On MS Vista today's (19. 09) 6.4.x SVN nightly is failing to open attribute table with error (can't copy it): 'columns' is not recognized as internal or external command... And then it still fails as per #1614

Strange...

there is already a ticket for the "columns"-issue: http://trac.osgeo.org/grass/ticket/1706

comment:7 in reply to:  6 Changed 7 years ago by hellik

Replying to hellik:

Replying to marisn:

Michael, please, can You specify what exactly is failing? Error messages?

On MS Vista today's (19. 09) 6.4.x SVN nightly is failing to open attribute table with error (can't copy it): 'columns' is not recognized as internal or external command... And then it still fails as per #1614

Strange...

there is already a ticket for the "columns"-issue: http://trac.osgeo.org/grass/ticket/1706

see http://trac.osgeo.org/grass/ticket/1706#comment:6

the columns-issue is solved.

comment:8 Changed 7 years ago by MilenaN

Using 6.4.3rc1 under windows 7, the manage table tab content is not greyed out since it is read only when the map is in a different mapset. This works under linux.

comment:9 in reply to:  8 ; Changed 7 years ago by hellik

Replying to MilenaN:

Using 6.4.3rc1 under windows 7, the manage table tab content is not greyed out since it is read only when the map is in a different mapset. This works under linux.

tested here with osgeo4w-grass6.4.3RC1:

  • if vector is wthin the used mapset, manage table tab content is editable
  • if vector is within another mapset, manage table tab content isn't editable

AFAIU this should is the GRASS-design of mapsets?

Helmut

comment:10 in reply to:  9 ; Changed 7 years ago by neteler

Replying to hellik:

  • if vector is within another mapset, manage table tab content isn't editable

In this case, is it also greyed out as it should to render it obvious as it does under Linux?

comment:11 in reply to:  10 ; Changed 7 years ago by hellik

Replying to neteler:

Replying to hellik:

  • if vector is within another mapset, manage table tab content isn't editable

In this case, is it also greyed out as it should to render it obvious as it does under Linux?

it isn't greyed out.

comment:12 in reply to:  11 Changed 7 years ago by neteler

Replying to hellik:

Replying to neteler:

Replying to hellik:

  • if vector is within another mapset, manage table tab content isn't editable

In this case, is it also greyed out as it should to render it obvious as it does under Linux?

it isn't greyed out.

So that's (one of) the bug(s). If greyed out winGRASS users would intuitively understand that a table from a different mapset cannot be edited. I wonder why this greying out works on Linux but not on Windows.

comment:13 Changed 7 years ago by neteler

Cc: wingrass attribute table manager added

comment:14 Changed 7 years ago by neteler

Cc: wingrass attribute table manager removed
Keywords: wingrass attribute table manager added

comment:15 in reply to:  description Changed 7 years ago by hellik

Resolution: duplicate
Status: newclosed

Replying to cmbarton:

People using Windows cannot access the table controls in the manage table page of the attribute table manager. This is broken for GRASS 6.4.2 also, but a fix was implemented in GRASS 7 in February or March of this year. I thought it was backported, but I guess it was not. This needs to be done. AFAICT, this affects all Windows versions.

duplication of #1270, closing ticket, because working fixes documented there.

Helmut

Note: See TracTickets for help on using tickets.