Opened 8 years ago

Closed 7 years ago

#1622 closed defect (fixed)

winGrass 7 error

Reported by: renatotonielli Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: Packaging Version: svn-trunk
Keywords: wingrass, compiling Cc: rsbivand
CPU: x86-64 Platform: MSWindows XP

Description

I installed the new version of Grass 7, but after installation I received this error.

'manpath' is not recognized as an internal or external command, operable program or batch file. Cleaning up temporary files... Starting GRASS GIS... ATTENZIONE: Il locking concorrente del mapset non Φ supportato in Windows.

_ _

/ / \/ | / _/ _/ / / _/ _/

/ / / /_/ / /| | \
_ \ / / / / \ \

/ /_/ / _, _/ _ |_/ // / / /_/ / _/ / \/_/ |_/_/ |_/// \/_/

Welcome to GRASS 7.0.svn GRASS homepage: http://grass.osgeo.org This version running through: shell (C:\WINDOWS\system32\cmd.exe) Help is available with the command: g.manual -i See the licence terms with: g.version -c If required, restart the GUI with: g.gui wxpython When ready to quit enter: exit

Launching <wxpython> GUI in the background, please wait... Microsoft Windows [Version 5.2.3790] (C) Copyright 1985-2003 Microsoft Corp.

E:\Program Files (x86)\GRASS GIS 7.0.svn\msys>3D view mode: grass_imagery.7.0.svn not found.

'g.list' is not recognized as an internal or external command, operable program or batch file.

'g.list' is not recognized as an internal or external command, operable program or batch file.

GRASS module 'g.region' not found. Unable to start map display window.

Change History (9)

comment:1 Changed 8 years ago by hellik

Summary: Grass 7 errorwinGrass 7 error

comment:2 Changed 8 years ago by hellik

Component: DisplayPackaging
Keywords: wingrass compiling added

comment:3 in reply to:  description Changed 8 years ago by hellik

Replying to renatotonielli:

I installed the new version of Grass 7, but after installation I received this error.

confirmed with WinGRASS-7.0.svn-r51108-187-Setup.exe

see compilation log http://wingrass.fsv.cvut.cz/grass70/logs/log-r51108-187/error.log

GRASS GIS compilation log
-------------------------
Started compilation: Mon Mar 19 02:53:58 GMT 2012
--
Errors in:
/osgeo4w/usr/src/grass_trunk/lib/vector/Vlib
/osgeo4w/usr/src/grass_trunk/lib/vector/vedit
/osgeo4w/usr/src/grass_trunk/lib/vector/neta
/osgeo4w/usr/src/grass_trunk/lib/imagery
/osgeo4w/usr/src/grass_trunk/lib/cluster
/osgeo4w/usr/src/grass_trunk/lib/sites
[...]

Helmut

comment:4 Changed 8 years ago by rsbivand

Cc: rsbivand added

Until this is resolved, please restore the last build that wasn't broken, r51025-179 of 10 March, which cannot now be downloaded. All the visible daily builds are broken - the platform is Windows XP thru 7, and presumably not just x64.

comment:5 in reply to:  4 ; Changed 8 years ago by mmetz

Replying to rsbivand:

Until this is resolved, please restore the last build that wasn't broken, r51025-179 of 10 March, which cannot now be downloaded. All the visible daily builds are broken - the platform is Windows XP thru 7, and presumably not just x64.

I fixed it in r51112, the bug was introduced with direct pg support. This is the second time that Vlib was broken because of the new pg support. I would very much like to have this new feature tested (more than successful compilation) by the developer implementing it before it becomes enabled by default.

Markus M

comment:6 in reply to:  5 Changed 8 years ago by martinl

Replying to mmetz:

Replying to rsbivand:

Until this is resolved, please restore the last build that wasn't broken, r51025-179 of 10 March, which cannot now be downloaded. All the visible daily builds are broken - the platform is Windows XP thru 7, and presumably not just x64.

I fixed it in r51112, the bug was introduced with direct pg support. This is the second time that Vlib was broken because of the new pg support. I would very much like to have this new feature tested (more than successful compilation) by the developer implementing it before it becomes enabled by default.

ops, sorry. Thanks for the quick fix. Martin

comment:7 in reply to:  5 ; Changed 8 years ago by hellik

Replying to mmetz:

I fixed it in r51112, the bug was introduced with direct pg support.

tested with WinGRASS-7.0.svn-r51117-188-Setup.exe

wingrass7-daily builds are back, thanks.

closing the ticket?

Helmut

comment:8 in reply to:  7 Changed 8 years ago by martinl

Replying to hellik:

wingrass7-daily builds are back, thanks.

closing the ticket?

I would say yes. I am planning to test direct PG support on Windows within few weeks. Then I will re-enable --with-postgres.

comment:9 Changed 7 years ago by neteler

Resolution: fixed
Status: newclosed

Closing as suggested in last comment. Feel free to reopen if needed.

Note: See TracTickets for help on using tickets.