Opened 10 years ago

Closed 4 years ago

Last modified 4 years ago

#1618 closed defect (worksforme)

d.rast.arrow displaying incorrectly in GRASS 7

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 7.0.7
Component: Display Version: svn-trunk
Keywords: d.rast.arrow Cc:
CPU: Unspecified Platform: Unspecified

Description

d.rast.arrow gives a variety of incorrect displays in GRASS 7, with multiple arrow for each cell and a change in arrow resolution when the align to grid option is chosen. It also does not display when the transparent option is checked for the null colors. The same problems occur with the Cairo and PNG drivers.

It is working correctly in GRASS 6.4.3.

I've posted screenshots of the same display (wind direction and velocity in AD 1000 in the N. Atlantic, in case you are wondering) from GRASS 6.4.3 and GRASS 7 to illustrate the problem

Attachments (2)

paleowind_G643.jpg (187.1 KB ) - added by cmbarton 10 years ago.
d.rast.arrow display in GRASS 6.4.3
paleowind_G7.jpg (184.7 KB ) - added by cmbarton 10 years ago.
d.rast.arrow display in GRASS 7

Download all attachments as: .zip

Change History (10)

by cmbarton, 10 years ago

Attachment: paleowind_G643.jpg added

d.rast.arrow display in GRASS 6.4.3

by cmbarton, 10 years ago

Attachment: paleowind_G7.jpg added

d.rast.arrow display in GRASS 7

comment:1 by cmbarton, 10 years ago

This is one of a series of rendering errors that have appeared in GRASS 7 (see also ticket #1410) that are making it hard to get nice output from GRASS 7. There are also problems with north arrows and grids. If these are related to the same underlying problem, all could be fixed at the same time. Do these problems show up on non-Mac systems?

Michael

comment:2 by hamish, 9 years ago

working now?

comment:3 by hamish, 9 years ago

looks ok for me now in spearfish. do you still see it? maybe only in a lat/lon location like the d.barscale bug?

Hamish

comment:4 by martinl, 6 years ago

Milestone: 7.0.07.0.5

comment:5 by neteler, 6 years ago

Milestone: 7.0.57.0.6

comment:6 by neteler, 4 years ago

Milestone: 7.0.67.0.7

comment:7 by martinl, 4 years ago

Resolution: worksforme
Status: newclosed

No activity for a long time. Closing. Feel free to reopen if needed.

comment:8 by cmbarton, 4 years ago

This seems to be fixed in trunk at least.

Note: See TracTickets for help on using tickets.