Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#1614 closed defect (fixed)

WXGUI regression - attribute table management doesn't work

Reported by: marisn Owned by: martinl
Priority: major Milestone: 6.4.3
Component: wxGUI Version: 6.4.2
Keywords: atm, table manager Cc: grass-dev@…
CPU: Unspecified Platform: MSWindows Vista

Description

When opening vector attribute table manager's tab "Manage tables", it's impossible to interact with any of it's GUI elements - adding a new column, renaming existing column, deleting existing column is not possible. GUI elements aren't grayed out, still it's not possible to enter values, use drop-down menus etc.

6.4.0 works just fine on the same vector map - a major issue as existing functionality has been broken in a stable release.

Change History (9)

comment:1 Changed 8 years ago by martinl

Cc: grass-dev@… added
Keywords: atm added
Owner: changed from grass-dev@… to martinl
Status: newassigned

Well, calling it a "regression" is quite offensive expression;-) You should be allowed to modify only attribute tables which are linked to the maps from your current mapset, make sense to you? See title of tab which contains info about *readonly* mode.

comment:2 in reply to:  1 Changed 8 years ago by martinl

Replying to martinl:

Well, calling it a "regression" is quite offensive expression;-) You should be allowed to modify only attribute tables which are linked to the maps from your current mapset, make sense to you? See title of tab which contains info about *readonly* mode.

ah I see, you are referring to winGRASS only. After some testing I can confirm that attribute manager is broken in the sense you reported in GRASS 6.4.2. Anyway GRASS 6.4.3 seems to be OK (please could you confirm it?)

comment:3 Changed 8 years ago by cmbarton

It works fine on the Mac in 6.4.2 and 6.4.3. So it just seems to be a Windows problem.

Michael

comment:4 Changed 8 years ago by cmbarton

Keywords: table manager added

Just working with a colleague who is trying to create a GRASS-based training workshop next summer. She is on Windows with 6.4.2 and indeed the table manager and layer manager windows are locked and inaccessible.

This is not an access issue because we tried it with a file freshly imported into a map set that she owns. This is a serious problem for data management with the Windows version.

If there is a fix that could be applied to the windows binary package it would be a big help.

Michael

comment:5 Changed 8 years ago by cmbarton

I'm planning to teach a graduate course using GRASS next fall and most students will probably have windows based systems. This is a serious problem that needs to be fixed for windows users. Is there a fix?

Michael

comment:6 in reply to:  5 Changed 8 years ago by martinl

Replying to cmbarton:

I'm planning to teach a graduate course using GRASS next fall and most students will probably have windows based systems. This is a serious problem that needs to be fixed for windows users. Is there a fix?

AFAIK no fix available. I would guess that we will release till autumn (September?) 6.4.3 which doesn't contain this bug.

comment:7 in reply to:  4 Changed 7 years ago by neteler

Replying to cmbarton:

Just working with a colleague who is trying to create a GRASS-based training workshop next summer. She is on Windows with 6.4.2 and indeed the table manager and layer manager windows are locked and inaccessible.

This is not an access issue because we tried it with a file freshly imported into a map set that she owns. This is a serious problem for data management with the Windows version.

Can you confirm that it now works in 6.4.svn?

comment:8 Changed 7 years ago by marisn

Resolution: fixed
Status: assignedclosed

Seems to be fixed. Closing.

comment:9 Changed 7 years ago by cmbarton

I can confirm that this is fixed on the Mac but don't have a way to test it on Windows. I assume that it works there too.

Michael

Note: See TracTickets for help on using tickets.