Opened 8 years ago

Closed 7 years ago

#1602 closed defect (fixed)

Error in i.points

Reported by: Venkat Owned by: grass-dev@…
Priority: major Milestone: 6.4.3
Component: wxGUI Version: 6.4.2
Keywords: georectifier Cc:
CPU: Unspecified Platform: MSWindows 7

Description

I'm attaching the error image and text of GRASS-6.4.2. Screen-shots for "Select maps to display for ground control point (GCP) creation" and message in command console. Cannot proceed to the next step "Manage Ground Control Points" .

i,points in GRASS-6.4.2RC was working well.


Traceback (most recent call last):

File "C:/Program Files (x86)/GRASS

6.4.2/etc/wxpython/wxgui.py", line 311, in OnGCPManager

gcpmanager.GCPWizard(self)

File "C:\Program Files (x86)\GRASS

6.4.2\etc\wxpython\gui_modules\gcpmanager.py", line 230, in init

Map=self.SrcMap?, lmgr=self.parent)

File "C:\Program Files (x86)\GRASS

6.4.2\etc\wxpython\gui_modules\gcpmanager.py", line 742, in init

Map=Map, toolbars=gcpdisp?, lmgr=lmgr, name='GCPMapWindow')

File "C:\Program Files (x86)\GRASS

6.4.2\etc\wxpython\gui_modules\gcpmapdisp.py", line 133, in init

self.AddToolbar?(toolb)

File "C:\Program Files (x86)\GRASS

6.4.2\etc\wxpython\gui_modules\gcpmapdisp.py", line 357, in AddToolbar?

self.toolbarsgcpdisp? = toolbars.GCPDisplayToolbar(self)

File "C:\Program Files (x86)\GRASS

6.4.2\etc\wxpython\gui_modules\toolbars.py", line 400, in init

style = wx.CB_READONLY)

File "C:\Program Files (x86)\GRASS 6.4.2\Python27\lib

\site-packages\wx-2.8-msw-unicode\wx\_controls.py", line 494, in init

_controls_.Choice_swiginit(self,_controls_.new_Choice(*args, kwargs)) wx._core . PyAssertionError? : C++ assertion "!(style & wxCB_DROPDOWN) && !(style & wxCB_READONLY) && !(style & wxCB_SIMPLE)" failed at ..\..\src\msw\choice.cpp(121) in wxChoice::Create(): this style flag is ignored by wxChoice, you probably want to use a wxComboBox

Attachments (2)

i-points_Error.png (51.2 KB) - added by Venkat 8 years ago.
i-points.png (12.8 KB) - added by Venkat 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Venkat

Attachment: i-points_Error.png added

Changed 8 years ago by Venkat

Attachment: i-points.png added

comment:1 Changed 8 years ago by martinl

Component: ImagerywxGUI
Keywords: georectifier added

comment:2 in reply to:  description Changed 8 years ago by mmetz

Replying to Venkat:

I'm attaching the error image and text of GRASS-6.4.2. Screen-shots for "Select maps to display for ground control point (GCP) creation" and message in command console. Cannot proceed to the next step "Manage Ground Control Points" .

i.points in GRASS-6.4.2RC was working well.

This error is caused by the recent upgrade of wxPython in the MSWindows installer. The new wxPython version does not allow features that were allowed, although probably ignored, in the previous version. Things get complicated because the same version of wxPython under Linux does not complain. I expect more such errors in the wingrass wxGUI to show up. This error should be fixed by now in all branches with r50178 - 80.

Markus M

comment:3 Changed 7 years ago by mmetz

Resolution: fixed
Status: newclosed

No more complaints, closing ticket. Please reopen if needed.

Markus M

Note: See TracTickets for help on using tickets.