Opened 11 years ago

Closed 10 years ago

#1544 closed defect (fixed)

(Windows/osgeo4w) libtiff.dll is broken

Reported by: lutra Owned by: grass-dev@…
Priority: normal Milestone: 6.4.2
Component: wxGUI Version: svn-releasebranch64
Keywords: wingrass, osgeo4w Cc: martinl
CPU: Unspecified Platform: MSWindows 7

Description

The module seems to work fine under Linux.

Under Windows/OSGeo4w/6.4.2rc3 when launching the module I get:

Traceback (most recent call last):
  File "C:/OSGeo4W/apps/grass/grass-6.4.2RC3/etc/wxpython/wx
gui.py", line 492, in OnMenuCmd

menuform.GUI(parent = self).ParseCommand(cmd)
  File "C:\OSGeo4W\apps\grass\grass-6.4.2RC3\etc\wxpython\gu
i_modules\menuform.py", line 1732, in ParseCommand

blackList = _blackList)
  File "C:\OSGeo4W\apps\grass\grass-6.4.2RC3\etc\python\gras
s\script\task.py", line 460, in parse_interface

tree = etree.fromstring(get_interface_description(name))
  File
"C:\OSGeo4W\apps\Python27\lib\xml\etree\ElementTree.py",
line 1283, in XML

return parser.close()
  File
"C:\OSGeo4W\apps\Python27\lib\xml\etree\ElementTree.py",
line 1636, in close

self._raiseerror(v)
  File
"C:\OSGeo4W\apps\Python27\lib\xml\etree\ElementTree.py",
line 1488, in _raiseerror

raise err
xml.etree.ElementTree
.
ParseError
:
no element found: line 1, column 0

When running it under QGIS I get the error message you can see in the attached image

Attachments (1)

errore.JPG (164.2 KB ) - added by lutra 11 years ago.

Download all attachments as: .zip

Change History (14)

by lutra, 11 years ago

Attachment: errore.JPG added

comment:1 by martinl, 11 years ago

Component: DefaultwxGUI
Keywords: wingrass added

comment:2 by martinl, 11 years ago

Cc: martinl added

in reply to:  description ; comment:3 by mmetz, 11 years ago

Replying to lutra:

The module seems to work fine under Linux.

When running it under QGIS I get the error message you can see in the attached image

That looks like a broken tiff library in the osgeo4w package. Try downgrading the tiff library through the osgeo4w package manager.

Markus M

in reply to:  3 ; comment:4 by lutra, 11 years ago

That looks like a broken tiff library in the osgeo4w package. Try downgrading the tiff library through the osgeo4w package manager.

correct, downgrading makes it work.

in reply to:  4 ; comment:5 by martinl, 11 years ago

Replying to lutra:

That looks like a broken tiff library in the osgeo4w package. Try downgrading the tiff library through the osgeo4w package manager.

correct, downgrading makes it work.

has been this bug in libtiff package already reported?

in reply to:  5 ; comment:6 by lutra, 11 years ago

has been this bug in libtiff package already reported?

don't think so. So it is just needed to file a ticket in the osgeo4w tracker?

in reply to:  6 ; comment:7 by mmetz, 11 years ago

Replying to lutra:

has been this bug in libtiff package already reported?

don't think so. So it is just needed to file a ticket in the osgeo4w tracker?

Yes please! Several different wingrass users (also MartinL) have experienced problems which could be solved by downgrading the osgeo4w libtiff package.

BTW, also make sure you are not using the osgeo4w proj4 package version 4.7.1, but 4.7.0, there are OS-independent bugs in proj4-4.7.1 which is not yet officially released but proj4 is a core component for other osgeo projects (most importantly gdal).

Markus M

in reply to:  7 comment:8 by lutra, 11 years ago

BTW, also make sure you are not using the osgeo4w proj4 package version 4.7.1, but 4.7.0, there are OS-independent bugs in proj4-4.7.1 which is not yet officially released but proj4 is a core component for other osgeo projects (most importantly gdal).

so also proj4-4.7.1 is bugged and need to be fixed/reported in osgeo4w?

in reply to:  7 ; comment:9 by lutra, 11 years ago

don't think so. So it is just needed to file a ticket in the osgeo4w tracker?

Yes please!

http://trac.osgeo.org/osgeo4w/ticket/257

in reply to:  7 comment:10 by lutra, 11 years ago

BTW, also make sure you are not using the osgeo4w proj4 package version 4.7.1, but 4.7.0, there are OS-independent bugs in proj4-4.7.1 which is not yet officially released but proj4 is a core component for other osgeo projects (most importantly gdal).

the version available now in osgeo4w is 4.7.0-4, so you may want to drop a mail to osgeo4w packagers *before* they package 4.7.1

comment:11 by hamish, 11 years ago

Keywords: osgeo4w added
Summary: (Windows/osgeo4w) r.out.tiff is broken(Windows/osgeo4w) libtiff.dll is broken

in reply to:  9 comment:12 by neteler, 10 years ago

Version: unspecifiedsvn-releasebranch64

Replying to lutra:

http://trac.osgeo.org/osgeo4w/ticket/257

From OSGeo4W tracker, warmerdam January 2012:

I have rebuilt the libtiff dll package with VC7.1 which did not use manifests and this made it so that the tiffinfo.exe binary works again.

It seems that any DLL built using manifests and depending on manifest oriented runtimes requires that the .exe also be built with manifests.

This is in place now, but I hope to do some investigation of a way forward that does not depend on ancient compiler versions.

Can this be closed?

comment:13 by neteler, 10 years ago

Resolution: fixed
Status: newclosed

No reaction, assuming that the problem is gone after rebuilt of the libtiff dll package in OSGeo4W. Closing, feel free to reopen if needed.

Note: See TracTickets for help on using tickets.