Opened 9 years ago

Closed 9 years ago

#1407 closed enhancement (fixed)

confusing error message after grass7 crash

Reported by: MilenaN Owned by: martinl
Priority: blocker Milestone: 6.4.2
Component: wxGUI Version: svn-trunk
Keywords: startup Cc: grass-dev@…
CPU: Unspecified Platform: Unspecified

Description

After crashed grass7 session grass complains about .gislock file. The message is unhelpful if the user doesn't know what to do. Please add an explanation for the needed step to fix the blocked grass installation.

Attachments (3)

leftover_gislock.png (32.0 KB) - added by MilenaN 9 years ago.
.gislock file present but no idea how to continue
linux_gislock.png (14.2 KB) - added by neteler 9 years ago.
Crashed GRASS session on Linux
wxgui_gislock.png (16.6 KB) - added by martinl 9 years ago.
remove gislock?

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by MilenaN

Attachment: leftover_gislock.png added

.gislock file present but no idea how to continue

comment:1 Changed 9 years ago by MilenaN

Checking with the file expolorer, the indicated file does not exist.

comment:2 Changed 9 years ago by martinl

Keywords: wingrass added
Platform: AllUnspecified

I think it's related only to Windows...

Changed 9 years ago by neteler

Attachment: linux_gislock.png added

Crashed GRASS session on Linux

comment:3 Changed 9 years ago by neteler

Keywords: wingrass removed

The problem is similar on Linux, see attachment.

Changed 9 years ago by martinl

Attachment: wxgui_gislock.png added

remove gislock?

comment:4 Changed 9 years ago by martinl

I have modified the dialog to allow remove gislock and continue (r47226) - see the attached screenshot. Would it help?

comment:5 in reply to:  1 Changed 9 years ago by martinl

Replying to MilenaN:

Checking with the file expolorer, the indicated file does not exist.

this should only refer to wingrass...

comment:6 Changed 9 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Status: newassigned

comment:7 Changed 9 years ago by martinl

Keywords: wxgui added

comment:8 in reply to:  4 ; Changed 9 years ago by martinl

Replying to martinl:

I have modified the dialog to allow remove gislock and continue (r47226) - see the attached screenshot. Would it help?

Backported to devbr6 in r47246. Testing welcomed.

comment:9 in reply to:  8 ; Changed 9 years ago by martinl

Replying to martinl:

Replying to martinl:

I have modified the dialog to allow remove gislock and continue (r47226) - see the attached screenshot. Would it help?

Backported to devbr6 in r47246. Testing welcomed.

Before closing the ticket, should it be also backported to relbr64?

comment:10 in reply to:  9 Changed 9 years ago by martinl

Resolution: fixed
Status: assignedclosed

Replying to martinl:

Replying to martinl:

Replying to martinl:

I have modified the dialog to allow remove gislock and continue (r47226) - see the attached screenshot. Would it help?

Backported to devbr6 in r47246. Testing welcomed.

Before closing the ticket, should it be also backported to relbr64?

Backported as r48257

comment:11 Changed 9 years ago by martinl

Component: StartupwxGUI
Keywords: startup added; wxgui removed

comment:12 in reply to:  4 ; Changed 9 years ago by hamish

Resolution: fixed
Status: closedreopened

Replying to martinl:

I have modified the dialog to allow remove gislock and continue (r47226) -

I would argue to make the warning a lot more dire and the functionality much harder to access.

the user is blocked from starting twice for a good reason, and it's for their own safety whether they realize it or not. Too many people are used to broken software and just click past "an error occurred -> ignore" without thinking about it.

since grass can crash too, or the power go out, etc, sure it's nice to allow recovery without filesystem hacks, but perhaps have it launch a second dialog saying "Are you sure? If you really are running another GRASS session doing this could corrupt your data. Have another look in the processor manager just to be sure.." or something like that.

Hamsih

comment:13 in reply to:  12 ; Changed 9 years ago by martinl

Priority: normalblocker

Replying to hamish:

the user is blocked from starting twice for a good reason, and it's for their own safety whether they realize it or not. Too many people are used to broken software and just click past "an error occurred -> ignore" without thinking about it.

since grass can crash too, or the power go out, etc, sure it's nice to allow recovery without filesystem hacks, but perhaps have it launch a second dialog saying "Are you sure? If you really are running another GRASS session doing this could corrupt your data. Have another look in the processor manager just to be sure.." or something like that.

Try r48565, backported to devbr in r48566 for testing. Is it better?

comment:14 in reply to:  13 Changed 9 years ago by martinl

Resolution: fixed
Status: reopenedclosed

Replying to martinl:

Try r48565, backported to devbr in r48566 for testing. Is it better?

Backported to relbr64 in r49016

Note: See TracTickets for help on using tickets.