Opened 11 years ago

Closed 8 years ago

#1343 closed defect (fixed)

v.buffer2: difference between Linux 32bit and 64bit

Reported by: mmetz Owned by: grass-dev@…
Priority: critical Milestone: 6.4.5
Component: Default Version: svn-develbranch6
Keywords: v.buffer Cc:
CPU: x86-64 Platform: Linux

Description

v.buffer2 (not original v.buffer) produces warning messages on Linux 64bit that are not apparent on Linux 32bit. The initial results differ slightly, the final result seems to be ok after lots of cleaning.

Reproducible with roadsmajor in nc_spm:

GRASS> v.buffer2 input=roadsmajor@PERMANENT output=roadsmajor_buf1_2000 distance=1000

WARNING: Next edge was visited but it is not the first one !!! breaking
         loop
WARNING: Next edge was visited but it is not the first one !!! breaking
         loop
WARNING: Next edge was visited but it is not the first one !!! breaking
         loop

No such warnings, but topological errors with distance=500, warnings like these but no topological errors with distance=1000 or larger.

Change History (6)

comment:1 by neteler, 8 years ago

Resolution: fixed
Status: newclosed

The current v.buffer is working well, closing.

comment:2 by mmetz, 8 years ago

Resolution: fixed
Status: closedreopened

Reopening because v.buffer works only in GRASS7 and only if it uses the GEOS algorithm. A backport to GRASS6 is possible.

comment:3 by neteler, 8 years ago

Keywords: v.buffer2 removed
Priority: normalcritical

(v.buffer2 is v.buffer for a while)

See also #2223

See also #1464

comment:4 by neteler, 8 years ago

v.buffer has been rebased on GEOS in r59970 which you now need to compile the module.

Please test the updated version of v.buffer in 6.4.svn.

comment:5 by neteler, 8 years ago

Milestone: 7.0.06.4.5

Done in G7, downgrading to G6 where GEOS support was added in r59970.

# G6:
v.buffer input=roadsmajor@PERMANENT output=roadsmajor_buf1_2000 distance=1000

Appears to work, closing (reopen if not).

Some fun performance comparison:

  • G6.4.svn: 43.19 sec
  • G7.0.svn: 7.59 sec

comment:6 by neteler, 8 years ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.