Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#112 closed defect (fixed)

GRASS-6.3.0RC6 fails saving current display geometry to named region in Tcl GUI

Reported by: 4everskiff Owned by: grass-dev@…
Priority: major Milestone: 6.3.0
Component: Tcl/Tk Version: 6.3.0 RCs
Keywords: Cc: marco.pasetti@…
CPU: Unspecified Platform: Unspecified

Description

WinGRASS-6.3.0RC6 (self installer):

GRASS crash applying the following command from map display: "Save current display geometry to named region" Error message: Error setting region: child process exited abnormally The "named region" file is created, though.

When trying to re-do the command using the same name for region, after pressing "Yes" to "Already existing/Overwrite" alert message, the following error displays:

Error reading current resolution with g.region: child process exited Attached the g.region.log

"Zoom to region" command works (reports no errors), but it displays the standard map region, because (I think) the selected named region has not been correctly created.

I also tried the same commands using wxpython GUI; both "Save display geometry to named region" and "Zoom to saved region" work fine.

Attachments (1)

g.region.log (642 bytes) - added by 4everskiff 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by 4everskiff

Attachment: g.region.log added

comment:1 Changed 12 years ago by marisn

Summary: WinGRASS-6.3.0RC6 fails saving current display geometry to named region in Tcl GUIGRASS-6.3.0RC6 fails saving current display geometry to named region in Tcl GUI

I can confirm this on 32bit Linux with rev. 30826 svn trunk. Removed Win part from summary.

comment:2 Changed 12 years ago by 4everskiff

Milestone: 6.4.06.3.0

comment:3 Changed 12 years ago by marisn

Resolution: fixed
Status: newclosed

Issue seems to be fixed now (with some help from Ivan Shmakov). r31019

comment:4 in reply to:  3 Changed 12 years ago by 4everskiff

Replying to marisn:

Issue seems to be fixed now (with some help from Ivan Shmakov). r31019

Perfect. I will try it as soon as possible. Marco

Note: See TracTickets for help on using tickets.