Opened 12 years ago

Closed 12 years ago

#109 closed defect (fixed)

wxgrass - d.vect and d.vect.chart: changing default checkbox options in GUI results in KeyError

Reported by: mlennert Owned by: martinl
Priority: major Milestone: 6.4.0
Component: Python Version: svn-trunk
Keywords: wxgrass d.vect KeyError Cc: grass-dev@…
CPU: Unspecified Platform: Unspecified

Description

The command line for d.vect displayed in properties window of a vector layer does not correspond to the options displayed by the GUI. E.g. add a new vector layer and chose a map (I'll use fields@user1 here). The command line shown at the bottom of the properties window shows d.vect map=fields@user1. This is fine as it means that for all other options, we use the default. For the type option, the default is "point,line,boundary,centroid,area,face" and this is what is shown in the GUI where all the check boxes are ticked. However, if I uncheck any of these boxes for the first time, I get the following type of KeyError?:

Traceback (most recent call last):

File "/home/mlennert/SRC/GRASS/grass_trunk/dist.i486-pc-linux-

gnu/etc/wxpython/gui_modules/menuform.py", line 1252, in OnCheckBoxMulti?

del currentValues[ theValue ] KeyError? : u'point'

OR

Traceback (most recent call last):

File "/home/mlennert/SRC/GRASS/grass_trunk/dist.i486-pc-linux-

gnu/etc/wxpython/gui_modules/menuform.py", line 1252, in OnCheckBoxMulti?

del currentValues[ theValue ] KeyError? : u'shape'

The same happens with the d.vect.chart type options.

Moritz

Change History (2)

comment:1 in reply to:  description Changed 12 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Status: newassigned

Replying to mlennert:

The command line for d.vect displayed in properties window of a vector layer does not correspond to the options displayed by the GUI. E.g. add a new vector layer and chose a map (I'll use fields@user1 here). The command line shown at the bottom of the properties window shows d.vect map=fields@user1. This is fine as it means that for all other options, we use the default. For the type option, the default is "point,line,boundary,centroid,area,face" and this is what is shown in the GUI where all the check boxes are ticked. However, if I uncheck any of these boxes for the first time, I get the following type of KeyError?:

Traceback (most recent call last):

File "/home/mlennert/SRC/GRASS/grass_trunk/dist.i486-pc-linux-

gnu/etc/wxpython/gui_modules/menuform.py", line 1252, in OnCheckBoxMulti?

del currentValues[ theValue ] KeyError? : u'point'

OR

Traceback (most recent call last):

File "/home/mlennert/SRC/GRASS/grass_trunk/dist.i486-pc-linux-

gnu/etc/wxpython/gui_modules/menuform.py", line 1252, in OnCheckBoxMulti?

del currentValues[ theValue ] KeyError? : u'shape'

The same happens with the d.vect.chart type options.

It seems to me I have fixed this issue some time ago, see r30478. I tested d.vect GUI dialog, no KeyError. ??

Martin

comment:2 Changed 12 years ago by mlennert

Resolution: fixed
Status: assignedclosed

Just tried again and cannot reproduce. Don't know what happened...

Closing bug as fixed.

Moritz

Note: See TracTickets for help on using tickets.