Opened 12 years ago

Closed 12 years ago

#1028 closed defect (fixed)

v.krige fails to start

Reported by: martinl Owned by: grass-dev@…
Priority: major Milestone: 6.5.0
Component: Vector Version: svn-develbranch6
Keywords: v.krige Cc:
CPU: x86-32 Platform: Linux

Description

v.krige.py
Traceback (most recent call last):
  File "/usr/local/src/grass6_devel/dist.i686-pc-linux-gnu/scripts/v.krige.py", line 421, in <module>
    main()
  File "/usr/local/src/grass6_devel/dist.i686-pc-linux-gnu/scripts/v.krige.py", line 318, in main
    controller = controller)
  File "/usr/local/src/grass6_devel/dist.i686-pc-linux-gnu/etc/wxpython/gui_modules/v_krige_wxGUI.py", line 278, in __init__
    self.Panel = KrigingPanel(self, Rinstance, controller)
  File "/usr/local/src/grass6_devel/dist.i686-pc-linux-gnu/etc/wxpython/gui_modules/v_krige_wxGUI.py", line 106, in __init__
    self.CreatePage(package = Rpackage, Rinstance = Rinstance, controller = controller)
  File "/usr/local/src/grass6_devel/dist.i686-pc-linux-gnu/etc/wxpython/gui_modules/v_krige_wxGUI.py", line 184, in CreatePage
    controller = controller)))
  File "/usr/local/src/grass6_devel/dist.i686-pc-linux-gnu/etc/wxpython/gui_modules/v_krige_wxGUI.py", line 403, in __init__
    ModelFactor = robjects.r.vgm().r['long']
AttributeError: 'DataFrame' object has no attribute 'r'

Change History (3)

comment:1 by aghisla, 12 years ago

Fixed in r42003, but the problem is now R package spgrass6 that fails reading GRASS7 vectors. I leave the ticket open.

comment:2 by aghisla, 12 years ago

sorry, wrong ticket - this one can be closed. Fixed in r42002.

comment:3 by aghisla, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.