Opened 6 years ago

Closed 5 years ago

#761 closed defect (wontfix)

PHP 7 support

Reported by: rrozitis Owned by: strk
Priority: blocker Milestone: 3.5.1
Component: PHP Version: main
Severity: Unassigned Keywords: php7
Cc:

Description

Currently it is impossible to build the php bindings/extension for PHP7 (7.0.1) (Zend API changes).

geos.c:619:63: error: macro "zend_hash_get_current_key" passed 4 arguments, but takes just 3
         while(zend_hash_get_current_key(style, &key, &index, 0)
                                                               ^
geos.c:619:15: error: 'zend_hash_get_current_key' undeclared (first use in this function)
         while(zend_hash_get_current_key(style, &key, &index, 0)
               ^
....

Are there any plans / timings if/when support for php7 lands?

Change History (1)

comment:1 Changed 5 years ago by strk

Resolution: wontfix
Status: newclosed

I'll start on the PHP7 port this week, but the PHP binding is moving to its own repo now, so this ticket was moved to: https://git.osgeo.org/gogs/geos/php-geos/issues/1

Note: See TracTickets for help on using tickets.