Opened 8 years ago

Closed 7 years ago

#600 closed defect (fixed)

[JTS works] TopologyException in ST_Union with valid geometries

Reported by: ppawel Owned by: geos-devel@…
Priority: major Milestone: 3.5.0
Component: Default Version: 3.3.6
Severity: Unassigned Keywords:
Cc: EliL

Description

In 3.3.6 a lot of issues with my dataset have been resolved but another one popped up shortly after today's release.

Attached is an SQL script with a number of geometries that are all valid. At the end of the script there's ST_Union aggregate which throws:

ERROR:  GEOSUnaryUnion: TopologyException: found non-noded intersection between LINESTRING (7.85872 48.7632, 7.85864 48.7631) and LINESTRING (7.85864 48.7631, 7.85864 48.7631) at 7.8586359309477531 48.763120943813725

Attachments (1)

script.sql.gz (65.3 KB) - added by ppawel 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by ppawel

Attachment: script.sql.gz added

comment:1 Changed 8 years ago by strk

Milestone: 3.3.73.3.x

should be tested with JTS...

comment:2 Changed 8 years ago by mdavis

The case works in JTS 1.13 using UnaryUnion?

comment:3 Changed 8 years ago by strk

Summary: TopologyException in ST_Union with valid geometries[JTS works] TopologyException in ST_Union with valid geometries

Martin reports this to work with JTS 1.13.

comment:4 Changed 8 years ago by EliL

Cc: EliL added

comment:5 Changed 7 years ago by robe

Milestone: 3.3.93.5.0

push

comment:6 Changed 7 years ago by strk

Resolution: fixed
Status: newclosed

I cannot reproduce here with POSTGIS="2.1.1dev r12013" GEOS="3.4.3dev-CAPI-1.8.3 r3958" Assuming fixed by 3.3.something (tried 3.3.9?) -- reopen if you cannot confirm

Note: See TracTickets for help on using tickets.