Opened 10 years ago

Closed 8 months ago

#460 closed enhancement (fixed)

Add 'M' EWKB support to WKBReader

Reported by: strk Owned by: geos-devel@…
Priority: major Milestone: 3.9.0
Component: Default Version: master
Severity: Unassigned Keywords:
Cc:

Description

Current WKBReader misinterprets EWKB with M values (The PostGIS extension to WKB). Correctly handles SRID and Z in it though...

Change History (8)

comment:1 Changed 10 years ago by strk

Milestone: 3.3.13.4.0
Type: defectenhancement
Version: 3.3.0svn-trunk

This is really an enhancement, not a bug..

comment:2 Changed 8 years ago by robe

Milestone: 3.4.03.5.0

comment:3 Changed 6 years ago by robe

Milestone: 3.5.03.6.0

comment:4 Changed 4 years ago by strk

Milestone: 3.6.03.7.0

Ticket retargeted after milestone closed

comment:5 Changed 4 years ago by robe

Milestone: 3.7.03.8.0

comment:6 Changed 19 months ago by pramsey

Milestone: 3.8.03.9.0

comment:7 Changed 8 months ago by Paul Ramsey <pramsey@…>

In 1d34d2c/git:

Support reading WKB that includes M coordinates, but do not actually store the M (because we have nowhere to store it right now). References #460

comment:8 Changed 8 months ago by pramsey

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.