Opened 11 years ago

Closed 11 years ago

#291 closed defect (fixed)

geos fails with -DNDEBUG

Reported by: xarth Owned by: pramsey
Priority: minor Milestone:
Component: Build/Install Version: 3.1.1
Severity: Unassigned Keywords:
Cc:

Description

Geos-3.1.1 fails to compile when configured with --disable-cassert. Affected files:

Attachments (1)

geos-3.1.1-missing-includes.patch (662 bytes) - added by xarth 11 years ago.
adding missing includes

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by xarth

adding missing includes

comment:1 Changed 11 years ago by pramsey

I can't reproduce this in 3.1 branch or trunk. The attached patch is also missing the change to XMLTester.cpp noted in the description. I'll apply the patch blind if you can confirm it is complete.

comment:2 in reply to:  1 Changed 11 years ago by xarth

Replying to pramsey:

I can't reproduce this in 3.1 branch or trunk. The attached patch is also missing the change to XMLTester.cpp noted in the description.

The patch is complete. It's trac issue that it doesn't show the whole file. If you download it in a raw format, everything is in place.

comment:3 Changed 11 years ago by pramsey

Resolution: fixed
Status: newclosed

Committed patch to 3.1 branch at r2722, trunk at r2723

Note: See TracTickets for help on using tickets.