Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#231 closed defect (duplicate)

Glibc error when statically linking Geos

Reported by: yvesdaemen Owned by: mloskot
Priority: major Milestone:
Component: Core Version: 3.0.3
Severity: Unassigned Keywords:
Cc:

Description

When I statically link my C-program against Geos, the program crashes at the very end.

I have been able to trace it back to the static string in io/WKBReader : BAD_GEOM_TYPE_MSG I cannot explain what goes wrong, but when I remove the static modifier (why is it there anyway?) and initialise the string inside the constructor, everything goes well.

Before I linked dynamically, and I also got (for me) unexplainable Valgrind warnings at the end of my program. They probably come out worse now...

Change History (3)

comment:1 by mloskot, 13 years ago

Owner: changed from geos-devel@… to mloskot
Status: newassigned

comment:2 by mloskot, 13 years ago

Resolution: duplicate
Status: assignedclosed

Closing this duplicate of #232

comment:3 by (none), 13 years ago

Milestone: 3.1.0

Milestone 3.1.0 deleted

Note: See TracTickets for help on using tickets.