Opened 7 years ago

Last modified 7 years ago

#6241 closed defect

gdalinfo error when reading Digital Globe NITF — at Initial Version

Reported by: dmedwrds Owned by: warmerdam
Priority: normal Milestone: 2.0.2
Component: default Version: 2.0.1
Severity: normal Keywords:
Cc:

Description

I am using GDAL v2.0.1 on Windows, built against OpenJPEG v2.0.

When I run gdalinfo on a Digital Globe NITF image with accompanying metadata files (.att, .eph, .geo, and so on), I am getting an error message. However, when I run gdalinfo on the same NITF image in a directory by itself, I do not see the error message. I believe this might indicate a problem with the Digital Globe metadata reader.

The error message is: ERROR 3: Cannot read 258523934 bytes where 258523934 is the number of bytes in the first image segment in the NITF file.

I have attached the output from running the command:

gdalinfo --debug on -nomd -nogcp 15OCT03110633-P1BS_R1C1-500380496130_01_P001.NTF

The gdal_failure.txt file is the output when I run the command in a directory containing the image and the associated metadata files. The gdal_success.txt file is the output from exactly the same command run on exactly the same image file, when the image file is in a directory by itself.

Change History (2)

by dmedwrds, 7 years ago

Attachment: gdal_failure.txt added

Output from call to gdalinfo with error case.

by dmedwrds, 7 years ago

Attachment: gdal_success.txt added

Output from successful call to gdalinfo.

Note: See TracTickets for help on using tickets.