Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6156 closed defect (duplicate)

FileGDB Layer Geometry Missing

Reported by: zhulongxing Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: 2.0.1
Severity: normal Keywords: geometry
Cc:

Description

I'm using gdal-2.0.1 version and the FileGDB API is by ESRI FileGDB SDK API 1.4.

Using the ogr2ogr.exe to convert the LanadParcel layer to Output layer, but there are some geometries missing, why??

please reference the attachment docs, thanks.

Attachments (2)

ogr2ogr_geometry_missing.jpg (75.8 KB ) - added by zhulongxing 7 years ago.
Testing.gdb.7z (216.1 KB ) - added by zhulongxing 7 years ago.

Download all attachments as: .zip

Change History (7)

by zhulongxing, 7 years ago

by zhulongxing, 7 years ago

Attachment: Testing.gdb.7z added

comment:1 by Even Rouault, 7 years ago

Resolution: duplicate
Status: newclosed

The missing geometries or geometry parts are curves. This is not currently supported. Closing as a duplicate of #5890

comment:2 by Even Rouault, 7 years ago

trunk r31018 "FileGDB/OpenFileGDB: mentions curve geometries are not supported (#6156, #5890)"

comment:3 by zhulongxing, 7 years ago

not supported?? oh, my god... is that will support in the near future? tanks~

in reply to:  3 comment:4 by Even Rouault, 7 years ago

Replying to zhulongxing:

not supported?? oh, my god... is that will support in the near future? tanks~

I could be interested in improving that, but I have no plan to do it for the moment on my spare time (understand: funding welcome)

comment:5 by Even Rouault, 7 years ago

Implemented per #5890

Note: See TracTickets for help on using tickets.