Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5983 closed defect (fixed)

Block cache is not safe w.r.t writes

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 2.0.0
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords:
Cc:

Description

There is a long-standing issue with the global block cache that can write dirty block with GDALRasterBand::IWriteBlock() from a thread B, while thread A is reading or writing from/into the same dataset.

Can be for example triggered with gdalwarp -multi and RPCDEM warping.

Change History (3)

comment:1 Changed 6 years ago by Even Rouault

Milestone: 2.0
Resolution: fixed
Status: newclosed

trunk r29282, branches/2.0 r29284 "Block cache: make block cache manager safe with respect to writing dirty blocks (#5983)"

comment:2 Changed 6 years ago by Even Rouault

Actually this is a duplicate of #3226

comment:3 Changed 6 years ago by Even Rouault

Milestone: 2.02.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.