Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5975 closed defect (fixed)

OpenAir detection limited to 10kb

Reported by: xmlich02 Owned by: warmerdam
Priority: normal Milestone: 2.0.0
Component: default Version: unspecified
Severity: normal Keywords: OpenAir
Cc:

Description

Description of problem: Gdal is using just 10kb for detection of OpenAir? format. In real world there are files with 30kb of comments (without "\nAC", "\nAN", "\nAL" and "\nAH")

For example http://soaringweb.org/Airspace/CZ/CZ_combined_2014_05_01.txt . It is valid OpenAir? file.

It seems the problem is caused by size of buffer char szBuffer[10000] in /ogr/ogrsf_frmts/openair/ogropenairdatasource.cpp and method int OGROpenAirDataSource::Open( const char * pszFilename, int bUpdateIn)

Version-Release number of selected component (if applicable): all versions

How reproducible: Always

Steps to Reproduce:

  1. wget http://soaringweb.org/Airspace/CZ/CZ_combined_2014_05_01.txt
  2. ogrinfo CZ_combined_2014_05_01.txt

Expected results: INFO: Open of `CZ_combined_2014_05_01.txt'

using driver `OpenAir?' successful.

1: airspaces (Polygon) 2: labels (Point)

Actual results: FAILURE: Unable to open datasource `CZ_combined_2014_05_01.txt' with the following drivers.

Change History (2)

comment:1 Changed 6 years ago by Even Rouault

Milestone: 2.0
Resolution: fixed
Status: newclosed

trunk r29253 "OpenAir? and SUA: tweak detection logic to read beyond first 10KB bytes when needed (#5975)"

comment:2 Changed 6 years ago by Even Rouault

Milestone: 2.02.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.